[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <671965a8b37a2_1bbc629489@dwillia2-xfh.jf.intel.com.notmuch>
Date: Wed, 23 Oct 2024 14:07:52 -0700
From: Dan Williams <dan.j.williams@...el.com>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>, "Huang, Ying"
<ying.huang@...el.com>
CC: David Hildenbrand <david@...hat.com>, Andrew Morton
<akpm@...ux-foundation.org>, <linux-mm@...ck.org>,
<linux-kernel@...r.kernel.org>, <linux-cxl@...r.kernel.org>, Dan Williams
<dan.j.williams@...el.com>, Davidlohr Bueso <dave@...olabs.net>, "Jonathan
Cameron" <jonathan.cameron@...wei.com>, Alistair Popple <apopple@...dia.com>,
Bjorn Helgaas <bhelgaas@...gle.com>, Baoquan He <bhe@...hat.com>, Dave Jiang
<dave.jiang@...el.com>, Alison Schofield <alison.schofield@...el.com>
Subject: Re: [RFC] resource: Avoid unnecessary resource tree walking in
__region_intersects()
[ I was sent here from 87msiw4j1m.fsf@...ang6-desk2.ccr.corp.intel.com,
can we please just create a for_each_resource_descendant() as Ying has
proposed? ]
Andy Shevchenko wrote:
> On Fri, Oct 11, 2024 at 09:06:37AM +0800, Huang, Ying wrote:
> > David Hildenbrand <david@...hat.com> writes:
> > > On 10.10.24 08:55, Huang Ying wrote:
>
> ...
>
> > > for ((_p) = (_root)->child; (_p); (_p) = next_resource_XXX(_root, _p))
> >
> > Yes. This can improve code readability.
> >
> > A possible issue is that "_root" will be evaluated twice in above macro
> > definition. IMO, this should be avoided.
>
> Ideally, yes. But how many for_each type of macros you see that really try hard
> to achieve that? I believe we shouldn't worry right now about this and rely on
> the fact that root is the given variable. Or do you have an example of what you
> suggested in the other reply, i.e. where it's an evaluation of the heavy call?
>
> > Do you have some idea about
> > how to do that? Something like below?
> >
> > #define for_each_resource_XXX(_root, _p) \
> > for (typeof(_root) __root = (_root), __p = (_p) = (__root)->child; \
> > __p && (_p); (_p) = next_resource_XXX(__root, _p))
>
> This is a bit ugly :-( I would avoid ugliness as long as we have no problem to
> solve (see above).
Using a local defined variable to avoid double evaluation is standard
practice. I do not understand "avoid ugliness as long as we have no problem to
solve", the problem to solve will be if someone accidentally does
something like "for_each_resource_descendant(root++, res)". *That* will
be a problem when someone finally realizes that the macro is hiding a
double evaluation.
So no, this proposal is not "ugly", it is a best practice. See the
definition of min_not_zero() for example.
Powered by blists - more mailing lists