lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <75ca3ac0-be7c-4be5-be50-11b90b690102@arm.com>
Date: Thu, 24 Oct 2024 11:24:14 +0100
From: Lukasz Luba <lukasz.luba@....com>
To: "Rafael J. Wysocki" <rjw@...ysocki.net>
Cc: LKML <linux-kernel@...r.kernel.org>, Linux PM <linux-pm@...r.kernel.org>,
 Daniel Lezcano <daniel.lezcano@...aro.org>, Zhang Rui <rui.zhang@...el.com>,
 Srinivas Pandruvada <srinivas.pandruvada@...ux.intel.com>
Subject: Re: [PATCH v1 06/10] thermal: core: Move some trip processing to
 thermal_trip_crossed()



On 10/16/24 12:29, Rafael J. Wysocki wrote:
> From: Rafael J. Wysocki <rafael.j.wysocki@...el.com>
> 
> Notice that some processing related to trip point crossing carried out
> in handle_thermal_trip() and thermal_zone_set_trip_temp() may as well
> be done in thermal_trip_crossed(), which allows code duplication to be
> reduced, so change the code accordingly.
> 
> No intentional functional impact.
> 
> Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@...el.com>
> ---
>   drivers/thermal/thermal_core.c |   21 ++++++++++-----------
>   drivers/thermal/thermal_trip.c |   17 ++++++-----------
>   2 files changed, 16 insertions(+), 22 deletions(-)
> 
> Index: linux-pm/drivers/thermal/thermal_core.c
> ===================================================================
> --- linux-pm.orig/drivers/thermal/thermal_core.c
> +++ linux-pm/drivers/thermal/thermal_core.c
> @@ -460,11 +460,6 @@ static void handle_thermal_trip(struct t
>   		if (tz->temperature < trip->temperature - trip->hysteresis) {
>   			td->notify_temp = trip->temperature - trip->hysteresis;
>   			move_trip_to_sorted_list(td, way_down_list);
> -
> -			if (trip->type == THERMAL_TRIP_PASSIVE) {
> -				tz->passive--;
> -				WARN_ON(tz->passive < 0);
> -			}
>   		} else {
>   			td->threshold -= trip->hysteresis;
>   		}
> @@ -478,12 +473,6 @@ static void handle_thermal_trip(struct t
>   		move_trip_to_sorted_list(td, way_up_list);
>   
>   		td->threshold -= trip->hysteresis;
> -
> -		if (trip->type == THERMAL_TRIP_PASSIVE)
> -			tz->passive++;
> -		else if (trip->type == THERMAL_TRIP_CRITICAL ||
> -			 trip->type == THERMAL_TRIP_HOT)
> -			handle_critical_trips(tz, trip);
>   	}
>   }
>   
> @@ -533,9 +522,19 @@ static void thermal_trip_crossed(struct
>   	const struct thermal_trip *trip = &td->trip;
>   
>   	if (crossed_up) {
> +		if (trip->type == THERMAL_TRIP_PASSIVE)
> +			tz->passive++;
> +		else if (trip->type == THERMAL_TRIP_CRITICAL ||
> +			 trip->type == THERMAL_TRIP_HOT)
> +			handle_critical_trips(tz, trip);
> +
>   		thermal_notify_tz_trip_up(tz, trip);
>   		thermal_debug_tz_trip_up(tz, trip);
>   	} else {
> +		if (trip->type == THERMAL_TRIP_PASSIVE) {
> +			tz->passive--;
> +			WARN_ON(tz->passive < 0);
> +		}
>   		thermal_notify_tz_trip_down(tz, trip);
>   		thermal_debug_tz_trip_down(tz, trip);
>   	}
> Index: linux-pm/drivers/thermal/thermal_trip.c
> ===================================================================
> --- linux-pm.orig/drivers/thermal/thermal_trip.c
> +++ linux-pm/drivers/thermal/thermal_trip.c
> @@ -108,18 +108,13 @@ void thermal_zone_set_trip_temp(struct t
>   	if (temp == THERMAL_TEMP_INVALID) {
>   		struct thermal_trip_desc *td = trip_to_trip_desc(trip);
>   
> -		if (tz->temperature >= td->threshold) {
> -			/*
> -			 * The trip has been crossed on the way up, so some
> -			 * adjustments are needed to compensate for the lack
> -			 * of it going forward.
> -			 */
> -			if (trip->type == THERMAL_TRIP_PASSIVE) {
> -				tz->passive--;
> -				WARN_ON_ONCE(tz->passive < 0);
> -			}
> +		/*
> +		 * If the trip has been crossed on the way up, some adjustments
> +		 * are needed to compensate for the lack of it going forward.
> +		 */
> +		if (tz->temperature >= td->threshold)
>   			thermal_zone_trip_down(tz, td);
> -		}
> +
>   		/*
>   		 * Invalidate the threshold to avoid triggering a spurious
>   		 * trip crossing notification when the trip becomes valid.
> 
> 
> 


Reviewed-by: Lukasz Luba <lukasz.luba@....com>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ