[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <933ab148-2a28-4912-9bca-150a0643eecd@efficios.com>
Date: Sun, 27 Oct 2024 08:30:54 -0400
From: Mathieu Desnoyers <mathieu.desnoyers@...icios.com>
To: Steven Rostedt <rostedt@...dmis.org>
Cc: linux-kernel@...r.kernel.org, Michael Jeanson <mjeanson@...icios.com>,
Masami Hiramatsu <mhiramat@...nel.org>, Peter Zijlstra
<peterz@...radead.org>, Alexei Starovoitov <ast@...nel.org>,
Yonghong Song <yhs@...com>, "Paul E . McKenney" <paulmck@...nel.org>,
Ingo Molnar <mingo@...hat.com>, Arnaldo Carvalho de Melo <acme@...nel.org>,
Mark Rutland <mark.rutland@....com>,
Alexander Shishkin <alexander.shishkin@...ux.intel.com>,
Namhyung Kim <namhyung@...nel.org>,
Andrii Nakryiko <andrii.nakryiko@...il.com>, bpf@...r.kernel.org,
Joel Fernandes <joel@...lfernandes.org>, Jordan Rife <jrife@...gle.com>,
Linus Torvalds <torvalds@...ux-foundation.org>
Subject: Re: [RFC PATCH v3 2/3] tracing: Introduce tracepoint_is_syscall()
On 2024-10-26 20:08, Steven Rostedt wrote:
> On Sat, 26 Oct 2024 11:46:28 -0400
> Mathieu Desnoyers <mathieu.desnoyers@...icios.com> wrote:
>
>> Introduce a "syscall" flag within the extended structure to know whether
>> a tracepoint needs rcu tasks trace grace period before reclaim.
>> This can be queried using tracepoint_is_syscall().
>>
>> Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@...icios.com>
>> Cc: Michael Jeanson <mjeanson@...icios.com>
>> Cc: Steven Rostedt <rostedt@...dmis.org>
>> Cc: Masami Hiramatsu <mhiramat@...nel.org>
>> Cc: Peter Zijlstra <peterz@...radead.org>
>> Cc: Alexei Starovoitov <ast@...nel.org>
>> Cc: Yonghong Song <yhs@...com>
>> Cc: Paul E. McKenney <paulmck@...nel.org>
>> Cc: Ingo Molnar <mingo@...hat.com>
>> Cc: Arnaldo Carvalho de Melo <acme@...nel.org>
>> Cc: Mark Rutland <mark.rutland@....com>
>> Cc: Alexander Shishkin <alexander.shishkin@...ux.intel.com>
>> Cc: Namhyung Kim <namhyung@...nel.org>
>> Cc: Andrii Nakryiko <andrii.nakryiko@...il.com>
>> Cc: bpf@...r.kernel.org
>> Cc: Joel Fernandes <joel@...lfernandes.org>
>> Cc: Jordan Rife <jrife@...gle.com>
>> ---
>> include/linux/tracepoint-defs.h | 2 ++
>> include/linux/tracepoint.h | 24 ++++++++++++++++++++++++
>> include/trace/define_trace.h | 2 +-
>> 3 files changed, 27 insertions(+), 1 deletion(-)
>>
>> diff --git a/include/linux/tracepoint-defs.h b/include/linux/tracepoint-defs.h
>> index 967c08d9da84..53119e074c87 100644
>> --- a/include/linux/tracepoint-defs.h
>> +++ b/include/linux/tracepoint-defs.h
>> @@ -32,6 +32,8 @@ struct tracepoint_func {
>> struct tracepoint_ext {
>> int (*regfunc)(void);
>> void (*unregfunc)(void);
>> + /* Flags. */
>> + unsigned int syscall:1;
>
> I wonder if we should call it "sleepable" instead? For this patch set
> do we really care if it's a system call or not? It's really if the
> tracepoint is sleepable or not that's the issue. System calls are just
> one user of it, there may be more in the future, and the changes to BPF
> will still be needed.
Remember that syscall tracepoint probes are allowed to handle page
faults, but should not generally block, otherwise it would postpone the
grace periods of all RCU tasks trace users.
So naming this "sleepable" would be misleading, because probes are
not allowed general blocking, just to handle page faults.
If we look at the history of this tracepoint feature, we went with
the following naming over the various versions of the patch series:
1) Sleepable tracepoints: until we understood that we just want to
allow page fault, not general sleeping, so we needed to change
the name,
2) Faultable tracepoints: until Linus requested that we aim for
something that is specific to system calls, rather than a generic
thing.
https://lore.kernel.org/lkml/CAHk-=wggDLDeTKbhb5hh--x=-DQd69v41137M72m6NOTmbD-cw@mail.gmail.com/
3) Syscall tracepoints: This is what we currently have.
> Other than that, I think this could work.
Calling this field "sleepable" would be misleading. Calling it "faultable"
would be a better fit, but based on Linus' request, I'm tempted to stick
with "syscall" for now.
Your concern is to name this in a way that is general and future-proof.
Linus' point was to make it syscall-specific rather than general. My
position is that we should wait until we face other use-cases (if we
even do) before consider changing the naming from "syscall" to something
more generic.
Thanks,
Mathieu
>
> -- Steve
>
>
>> };
>>
>> struct tracepoint {
>> diff --git a/include/linux/tracepoint.h b/include/linux/tracepoint.h
>> index 83dc24ee8b13..93e70bc64533 100644
>> --- a/include/linux/tracepoint.h
>> +++ b/include/linux/tracepoint.h
>> @@ -104,6 +104,12 @@ void for_each_tracepoint_in_module(struct module *mod,
>> * tracepoint_synchronize_unregister must be called between the last tracepoint
>> * probe unregistration and the end of module exit to make sure there is no
>> * caller executing a probe when it is freed.
>> + *
>> + * An alternative is to use the following for batch reclaim associated
>> + * with a given tracepoint:
>> + *
>> + * - tracepoint_is_syscall() == false: call_rcu()
>> + * - tracepoint_is_syscall() == true: call_rcu_tasks_trace()
>> */
>> #ifdef CONFIG_TRACEPOINTS
>> static inline void tracepoint_synchronize_unregister(void)
>> @@ -111,9 +117,17 @@ static inline void tracepoint_synchronize_unregister(void)
>> synchronize_rcu_tasks_trace();
>> synchronize_rcu();
>> }
>> +static inline bool tracepoint_is_syscall(struct tracepoint *tp)
>> +{
>> + return tp->ext && tp->ext->syscall;
>> +}
>> #else
>> static inline void tracepoint_synchronize_unregister(void)
>> { }
>> +static inline bool tracepoint_is_syscall(struct tracepoint *tp)
>> +{
>> + return false;
>> +}
>> #endif
>>
>> #ifdef CONFIG_HAVE_SYSCALL_TRACEPOINTS
>> @@ -345,6 +359,15 @@ static inline struct tracepoint *tracepoint_ptr_deref(tracepoint_ptr_t *p)
>> struct tracepoint_ext __tracepoint_ext_##_name = { \
>> .regfunc = _reg, \
>> .unregfunc = _unreg, \
>> + .syscall = false, \
>> + }; \
>> + __DEFINE_TRACE_EXT(_name, &__tracepoint_ext_##_name, PARAMS(_proto), PARAMS(_args));
>> +
>> +#define DEFINE_TRACE_SYSCALL(_name, _reg, _unreg, _proto, _args) \
>> + struct tracepoint_ext __tracepoint_ext_##_name = { \
>> + .regfunc = _reg, \
>> + .unregfunc = _unreg, \
>> + .syscall = true, \
>> }; \
>> __DEFINE_TRACE_EXT(_name, &__tracepoint_ext_##_name, PARAMS(_proto), PARAMS(_args));
>>
>> @@ -389,6 +412,7 @@ static inline struct tracepoint *tracepoint_ptr_deref(tracepoint_ptr_t *p)
>> #define __DECLARE_TRACE_SYSCALL __DECLARE_TRACE
>>
>> #define DEFINE_TRACE_FN(name, reg, unreg, proto, args)
>> +#define DEFINE_TRACE_SYSCALL(name, reg, unreg, proto, args)
>> #define DEFINE_TRACE(name, proto, args)
>> #define EXPORT_TRACEPOINT_SYMBOL_GPL(name)
>> #define EXPORT_TRACEPOINT_SYMBOL(name)
>> diff --git a/include/trace/define_trace.h b/include/trace/define_trace.h
>> index ff5fa17a6259..63fea2218afa 100644
>> --- a/include/trace/define_trace.h
>> +++ b/include/trace/define_trace.h
>> @@ -48,7 +48,7 @@
>>
>> #undef TRACE_EVENT_SYSCALL
>> #define TRACE_EVENT_SYSCALL(name, proto, args, struct, assign, print, reg, unreg) \
>> - DEFINE_TRACE_FN(name, reg, unreg, PARAMS(proto), PARAMS(args))
>> + DEFINE_TRACE_SYSCALL(name, reg, unreg, PARAMS(proto), PARAMS(args))
>>
>> #undef TRACE_EVENT_NOP
>> #define TRACE_EVENT_NOP(name, proto, args, struct, assign, print)
>
--
Mathieu Desnoyers
EfficiOS Inc.
https://www.efficios.com
Powered by blists - more mailing lists