[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20241029124029.GM1615717@unreal>
Date: Tue, 29 Oct 2024 14:40:29 +0200
From: Leon Romanovsky <leon@...nel.org>
To: Junxian Huang <huangjunxian6@...ilicon.com>
Cc: jgg@...pe.ca, linux-rdma@...r.kernel.org, linuxarm@...wei.com,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH for-next 9/9] RDMA/hns: Fix different dgids mapping to
the same dip_idx
On Thu, Oct 17, 2024 at 09:21:45PM +0800, Junxian Huang wrote:
>
>
> On 2024/9/10 21:12, Leon Romanovsky wrote:
> > On Fri, Sep 06, 2024 at 05:34:44PM +0800, Junxian Huang wrote:
> >> From: Feng Fang <fangfeng4@...wei.com>
> >>
> >> DIP algorithm requires a one-to-one mapping between dgid and dip_idx.
> >> Currently a queue 'spare_idx' is used to store QPN of QPs that use
> >> DIP algorithm. For a new dgid, use a QPN from spare_idx as dip_idx.
> >> This method lacks a mechanism for deduplicating QPN, which may result
> >> in different dgids sharing the same dip_idx and break the one-to-one
> >> mapping requirement.
> >>
> >> This patch replaces spare_idx with two new bitmaps: qpn_bitmap to record
> >> QPN that is not being used as dip_idx, and dip_idx_map to record QPN
> >> that is being used. Besides, introduce a reference count of a dip_idx
> >> to indicate the number of QPs that using this dip_idx. When creating
> >> a DIP QP, if it has a new dgid, set the corresponding bit in dip_idx_map,
> >> otherwise add 1 to the reference count of the reused dip_idx and set bit
> >> in qpn_bitmap. When destroying a DIP QP, decrement the reference count
> >> by 1. If it becomes 0, set bit in qpn_bitmap and clear bit in dip_idx_map.
> >>
> >> Fixes: eb653eda1e91 ("RDMA/hns: Bugfix for incorrect association between dip_idx and dgid")
> >> Fixes: f91696f2f053 ("RDMA/hns: Support congestion control type selection according to the FW")
> >> Signed-off-by: Feng Fang <fangfeng4@...wei.com>
> >> Signed-off-by: Junxian Huang <huangjunxian6@...ilicon.com>
> >> ---
> >> drivers/infiniband/hw/hns/hns_roce_device.h | 6 +--
> >> drivers/infiniband/hw/hns/hns_roce_hw_v2.c | 58 ++++++++++++++++++---
> >> drivers/infiniband/hw/hns/hns_roce_hw_v2.h | 1 +
> >> drivers/infiniband/hw/hns/hns_roce_qp.c | 16 ++++--
> >> 4 files changed, 67 insertions(+), 14 deletions(-)
> >
> > It is strange implementation, double bitmap and refcount looks like
> > open-coding of some basic coding patterns. Let's wait with applying it
> > for now.
> >
>
> Hi Leon, it's been a while since this patch was sent. Is it okay to be applied?
Not in this implementation. I think that xarray + tag will give you what
you are looking without the need to open-code it.
Thanks
>
> Regarding your question about the double bitmaps, that's because we have 3 states
> to track:
> 1) the context hasn't been created
> 2) the context has been created but not used as dip_ctx
> 3) the context is being used as dip_ctx.
>
> Junxian
>
> > Thanks
> >
>
Powered by blists - more mailing lists