lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ee7fd6ca-a5ad-47fe-8526-49ed2f7cc341@stanley.mountain>
Date: Fri, 1 Nov 2024 22:59:56 +0300
From: Dan Carpenter <dan.carpenter@...aro.org>
To: Dave Penkler <dpenkler@...il.com>
Cc: gregkh@...uxfoundation.org, linux-staging@...ts.linux.dev,
	linux-kernel@...r.kernel.org, skhan@...uxfoundation.org,
	arnd@...db.de
Subject: Re: [PATCH 9/9] Correct check for max secondary address

On Fri, Nov 01, 2024 at 06:47:05PM +0100, Dave Penkler wrote:
>   GPIB secondary addresses can be between 0 and 31 inclusive
>   unlike primary addresses where address 31 is used for UNT and UNL

What do UNT and UNL stand for?  I don't know what those words mean.

I can tell from looking at the patch that this is a behavior change, but I don't
know from the commit what the change will look like to the user.  Please,
explain that better in the commit message.

> 
> Signed-off-by: Dave Penkler <dpenkler@...il.com>
> ---
>  drivers/staging/gpib/common/gpib_os.c | 3 +--
>  drivers/staging/gpib/common/iblib.c   | 4 ++--
>  2 files changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/staging/gpib/common/gpib_os.c b/drivers/staging/gpib/common/gpib_os.c
> index c0b774a831a6..65ab190ac68e 100644
> --- a/drivers/staging/gpib/common/gpib_os.c
> +++ b/drivers/staging/gpib/common/gpib_os.c
> @@ -525,7 +525,6 @@ int serial_poll_all(gpib_board_t *board, unsigned int usec_timeout)
>   * SPD and UNT are sent at the completion of the poll.
>   */
>  
> -static const int gpib_addr_max = 30;	/* max address for primary/secondary gpib addresses */
>  

You'd want to delete the blank line as well otherwise you're left with two
blank lines in a row.

>  int dvrsp(gpib_board_t *board, unsigned int pad, int sad,
>  	  unsigned int usec_timeout, uint8_t *result)
> @@ -538,7 +537,7 @@ int dvrsp(gpib_board_t *board, unsigned int pad, int sad,
>  		return -1;
>  	}
>  
> -	if (pad > gpib_addr_max || sad > gpib_addr_max) {
> +	if (pad > 30 || sad > 31) {

These should be a define instead of a magic number.

regards,
dan carpenter


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ