lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20241112145159.23032-1-frederic@kernel.org>
Date: Tue, 12 Nov 2024 15:51:43 +0100
From: Frederic Weisbecker <frederic@...nel.org>
To: LKML <linux-kernel@...r.kernel.org>
Cc: Frederic Weisbecker <frederic@...nel.org>,
	Boqun Feng <boqun.feng@...il.com>,
	Joel Fernandes <joel@...lfernandes.org>,
	Josh Triplett <josh@...htriplett.org>,
	Lai Jiangshan <jiangshanlai@...il.com>,
	Mathieu Desnoyers <mathieu.desnoyers@...icios.com>,
	Neeraj Upadhyay <neeraj.upadhyay@....com>,
	"Paul E . McKenney" <paulmck@...nel.org>,
	Steven Rostedt <rostedt@...dmis.org>,
	Uladzislau Rezki <urezki@...il.com>,
	Zqiang <qiang.zhang1211@...il.com>,
	rcu <rcu@...r.kernel.org>
Subject: [PATCH 00/16] SRCU for v6.13

Hello,

Please find below the SRCU patches targeted for the upcoming
merge window.

Paul E. McKenney (15):
  srcu: Rename srcu_might_be_idle() to srcu_should_expedite()
  srcu: Introduce srcu_gp_is_expedited() helper function
  srcu: Renaming in preparation for additional reader flavor
  srcu: Bit manipulation changes for additional reader flavor
  srcu: Standardize srcu_data pointers to "sdp" and similar
  srcu: Improve srcu_read_lock{,_nmisafe}() comments
  srcu: Create CPP macros for normal and NMI-safe SRCU readers
  srcu: Add srcu_read_lock_lite() and srcu_read_unlock_lite()
  srcu: Allow inlining of __srcu_read_{,un}lock_lite()
  rcutorture: Expand RCUTORTURE_RDR_MASK_[12] to eight bits
  rcutorture: Add reader_flavor parameter for SRCU readers
  rcutorture: Add srcu_read_lock_lite() support to
    rcutorture.reader_flavor
  rcutorture: Add light-weight SRCU scenario
  refscale: Add srcu_read_lock_lite() support using "srcu-lite"
  srcu: Improve srcu_read_lock_lite() kernel-doc comment

Zhen Lei (1):
  srcu: Replace WARN_ON_ONCE() with BUILD_BUG_ON() if possible

 .../admin-guide/kernel-parameters.txt         |   8 ++
 include/linux/srcu.h                          |  90 ++++++++++---
 include/linux/srcutree.h                      |  46 ++++++-
 kernel/rcu/rcutorture.c                       |  65 +++++----
 kernel/rcu/refscale.c                         |  37 +++++-
 kernel/rcu/srcutree.c                         | 123 +++++++++++-------
 .../selftests/rcutorture/configs/rcu/CFLIST   |   1 +
 .../selftests/rcutorture/configs/rcu/SRCU-L   |  10 ++
 .../rcutorture/configs/rcu/SRCU-L.boot        |   3 +
 .../rcutorture/configs/rcu/SRCU-N.boot        |   1 +
 .../selftests/rcutorture/configs/rcu/TREE10   |   2 +-
 11 files changed, 295 insertions(+), 91 deletions(-)
 create mode 100644 tools/testing/selftests/rcutorture/configs/rcu/SRCU-L
 create mode 100644 tools/testing/selftests/rcutorture/configs/rcu/SRCU-L.boot

Thanks.
-- 
2.46.0


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ