[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <cover.1731406254.git.mchehab+huawei@kernel.org>
Date: Tue, 12 Nov 2024 11:14:44 +0100
From: Mauro Carvalho Chehab <mchehab+huawei@...nel.org>
To: Igor Mammedov <imammedo@...hat.com>
Cc: Jonathan Cameron <Jonathan.Cameron@...wei.com>,
Shiju Jose <shiju.jose@...wei.com>,
Mauro Carvalho Chehab <mchehab+huawei@...nel.org>,
"Michael S. Tsirkin" <mst@...hat.com>,
Ani Sinha <anisinha@...hat.com>,
Dongjiu Geng <gengdongjiu1@...il.com>,
Paolo Bonzini <pbonzini@...hat.com>,
Peter Maydell <peter.maydell@...aro.org>,
Shannon Zhao <shannon.zhaosl@...il.com>,
kvm@...r.kernel.org,
linux-kernel@...r.kernel.org,
qemu-arm@...gnu.org,
qemu-devel@...gnu.org
Subject: [PATCH v3 00/15] Prepare GHES driver to support error injection
During the development of a patch series meant to allow GHESv2 error injections,
it was requested a change on how CPER offsets are calculated, by adding a new
BIOS pointer and reworking the GHES logic. See:
https://lore.kernel.org/qemu-devel/cover.1726293808.git.mchehab+huawei@kernel.org/
Such change ended being a big patch, so several intermediate steps are needed,
together with several cleanups and renames.
As agreed duing v10 review, I'll be splitting the big patch series into separate pull
requests, starting with the cleanup series. This is the first patch set, containing
only such preparation patches.
The next series will contain the shift to use offsets from the location of the
HEST table, together with a migration logic to make it compatible with 9.1.
---
v3:
- improved some patch descriptions;
- some patches got reordered to better reflect the changes;
- patch v2 08/15: acpi/ghes: Prepare to support multiple sources on ghes
was split on two patches. The first one is in this cleanup series:
acpi/ghes: Change ghes fill logic to work with only one source
contains just the simplification logic. The actual preparation will
be moved to this series:
https://lore.kernel.org/qemu-devel/cover.1727782588.git.mchehab+huawei@kernel.org/
v2:
- some indentation fixes;
- some description improvements;
- fixed a badly-solved merge conflict that ended renaming a parameter.
Mauro Carvalho Chehab (15):
acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED
acpi/ghes: simplify acpi_ghes_record_errors() code
acpi/ghes: simplify the per-arch caller to build HEST table
acpi/ghes: better handle source_id and notification
acpi/ghes: Fix acpi_ghes_record_errors() argument
acpi/ghes: Remove a duplicated out of bounds check
acpi/ghes: Change the type for source_id
acpi/ghes: make the GHES record generation more generic
acpi/ghes: better name GHES memory error function
acpi/ghes: don't crash QEMU if ghes GED is not found
acpi/ghes: rename etc/hardware_error file macros
acpi/ghes: better name the offset of the hardware error firmware
acpi/ghes: move offset calculus to a separate function
acpi/ghes: Change ghes fill logic to work with only one source
docs: acpi_hest_ghes: fix documentation for CPER size
docs/specs/acpi_hest_ghes.rst | 6 +-
hw/acpi/generic_event_device.c | 4 +-
hw/acpi/ghes-stub.c | 2 +-
hw/acpi/ghes.c | 256 +++++++++++++++++++--------------
hw/arm/virt-acpi-build.c | 5 +-
include/hw/acpi/ghes.h | 17 ++-
target/arm/kvm.c | 3 +-
7 files changed, 171 insertions(+), 122 deletions(-)
--
2.47.0
Powered by blists - more mailing lists