lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20241114161744.GA2078@lst.de>
Date: Thu, 14 Nov 2024 17:17:44 +0100
From: Christoph Hellwig <hch@....de>
To: Chinmay Gameti <c.gameti@...sung.com>
Cc: axboe@...nel.dk, hch@....de, kbusch@...nel.org,
	linux-block@...r.kernel.org, linux-kernel@...r.kernel.org,
	joshi.k@...sung.com, anuj20.g@...sung.com, nj.shetty@...sung.com,
	kundan.kumar@...sung.com, gost.dev@...sung.com
Subject: Re: [PATCH] block: add larger order folio instead of pages for
 passthrough I/O

On Thu, Nov 14, 2024 at 07:23:35PM +0530, Chinmay Gameti wrote:
> +unsigned int get_contig_folio_len(unsigned int *num_pages,
> +				  struct page **pages, unsigned int i,
> +				  struct folio *folio, size_t left,
> +				  size_t offset)

Not a good name for a non-static function (not even for a stic
one to be honest).

> @@ -313,21 +314,35 @@ static int bio_map_user_iov(struct request *rq, struct iov_iter *iter,
>  		if (unlikely(offs & queue_dma_alignment(rq->q)))
>  			j = 0;
>  		else {
> -			for (j = 0; j < npages; j++) {
> +			for (j = 0; j < npages; j += num_pages) {
>  				struct page *page = pages[j];
> -				unsigned int n = PAGE_SIZE - offs;
> +				struct folio *folio = page_folio(page);
>  				bool same_page = false;
>  
> -				if (n > bytes)
> -					n = bytes;
>  
> -				if (!bio_add_hw_page(rq->q, bio, page, n, offs,
> -						     max_sectors, &same_page))
> +				folio_offset = ((size_t)folio_page_idx(folio,
> +						page) << PAGE_SHIFT) + offs;

I'm not sure if Jens want to rush something like this in for 6.13, but if
we're aiming for the next merge window I actually have a 3/4 done series
that rips out bio_add_hw_page and all the passthrough special casing by
simply running the 'do we need to split the bio' helper on the free-form
bio and return an error if we do.  That means all this code will go away,
and you'll automatically get all the work done for the normal path for
passthrough as well.

> diff --git a/include/linux/bio.h b/include/linux/bio.h
> index 60830a6a5939..1e5fbc875ecc 100644
> --- a/include/linux/bio.h
> +++ b/include/linux/bio.h
> @@ -422,6 +422,10 @@ void __bio_add_page(struct bio *bio, struct page *page,
>  		unsigned int len, unsigned int off);
>  void bio_add_folio_nofail(struct bio *bio, struct folio *folio, size_t len,
>  			  size_t off);
> +unsigned int get_contig_folio_len(unsigned int *num_pages,
> +				  struct page **pages, unsigned int i,
> +				  struct folio *folio, size_t left,
> +				  size_t offset);

And this really should bot be in a public header.


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ