[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <2c52e1a0-8431-47ca-9a27-153435805963@bytedance.com>
Date: Thu, 14 Nov 2024 12:12:14 +0800
From: Qi Zheng <zhengqi.arch@...edance.com>
To: David Hildenbrand <david@...hat.com>
Cc: jannh@...gle.com, hughd@...gle.com, willy@...radead.org, mgorman@...e.de,
muchun.song@...ux.dev, vbabka@...nel.org, akpm@...ux-foundation.org,
zokeefe@...gle.com, rientjes@...gle.com, peterx@...hat.com,
catalin.marinas@....com, linux-mm@...ck.org, linux-kernel@...r.kernel.org,
x86@...nel.org
Subject: Re: [PATCH v2 3/7] mm: introduce do_zap_pte_range()
On 2024/11/14 11:09, Qi Zheng wrote:
>
>
> On 2024/11/13 19:43, David Hildenbrand wrote:
>> On 13.11.24 03:40, Qi Zheng wrote:
>>>
>>>
>>> On 2024/11/13 01:00, David Hildenbrand wrote:
>>>> On 31.10.24 09:13, Qi Zheng wrote:
>>>>> This commit introduces do_zap_pte_range() to actually zap the PTEs,
>>>>> which
>>>>> will help improve code readability and facilitate secondary
>>>>> checking of
>>>>> the processed PTEs in the future.
>>>>>
>>>>> No functional change.
>>>>>
>>>>> Signed-off-by: Qi Zheng <zhengqi.arch@...edance.com>
>>>>> ---
>>>>> mm/memory.c | 45 ++++++++++++++++++++++++++-------------------
>>>>> 1 file changed, 26 insertions(+), 19 deletions(-)
>>>>>
>>>>> diff --git a/mm/memory.c b/mm/memory.c
>>>>> index bd9ebe0f4471f..c1150e62dd073 100644
>>>>> --- a/mm/memory.c
>>>>> +++ b/mm/memory.c
>>>>> @@ -1657,6 +1657,27 @@ static inline int zap_nonpresent_ptes(struct
>>>>> mmu_gather *tlb,
>>>>> return nr;
>>>>> }
>>>>> +static inline int do_zap_pte_range(struct mmu_gather *tlb,
>>>>> + struct vm_area_struct *vma, pte_t *pte,
>>>>> + unsigned long addr, unsigned long end,
>>>>> + struct zap_details *details, int *rss,
>>>>> + bool *force_flush, bool *force_break)
>>>>> +{
>>>>> + pte_t ptent = ptep_get(pte);
>>>>> + int max_nr = (end - addr) / PAGE_SIZE;
>>>>> +
>>>>> + if (pte_none(ptent))
>>>>> + return 1;
>>>>
>>>> Maybe we should just skip all applicable pte_none() here directly.
>>>
>>> Do you mean we should keep pte_none() case in zap_pte_range()? Like
>>> below:
>>>
>>
>> No rather an addon patch that will simply skip over all
>> consecutive pte_none, like:
>>
>> if (pte_none(ptent)) {
>> int nr;
>>
>> for (nr = 1; nr < max_nr; nr++) {
>> ptent = ptep_get(pte + nr);
>> if (pte_none(ptent))
>> continue;
>> }
>>
>> max_nr -= nr;
>> if (!max_nr)
>> return nr;
>> addr += nr * PAGE_SIZE;
>> pte += nr;
>> }
>
> I tend to hand over the pte/addr increments here to the loop
> outside do_zap_pte_range(), like this:
>
Finally, I choose to introduce skip_none_ptes() to do this:
diff --git a/mm/memory.c b/mm/memory.c
index bd9ebe0f4471f..24633d0e1445a 100644
--- a/mm/memory.c
+++ b/mm/memory.c
@@ -1657,6 +1657,28 @@ static inline int zap_nonpresent_ptes(struct
mmu_gather *tlb,
return nr;
}
+static inline int skip_none_ptes(pte_t *pte, unsigned long addr,
+ unsigned long end)
+{
+ pte_t ptent = ptep_get(pte);
+ int max_nr;
+ int nr;
+
+ if (!pte_none(ptent))
+ return 0;
+
+ max_nr = (end - addr) / PAGE_SIZE;
+ nr = 1;
+
+ for (; nr < max_nr; nr++) {
+ ptent = ptep_get(pte + nr);
+ if (!pte_none(ptent))
+ break;
+ }
+
+ return nr;
+}
+
static unsigned long zap_pte_range(struct mmu_gather *tlb,
struct vm_area_struct *vma, pmd_t *pmd,
unsigned long addr, unsigned long end,
@@ -1682,13 +1704,17 @@ static unsigned long zap_pte_range(struct
mmu_gather *tlb,
pte_t ptent = ptep_get(pte);
int max_nr;
- nr = 1;
- if (pte_none(ptent))
- continue;
-
if (need_resched())
break;
+ nr = skip_none_ptes(pte, addr, end);
+ if (nr) {
+ addr += PAGE_SIZE * nr;
+ if (addr == end)
+ break;
+ pte += nr;
+ }
+
max_nr = (end - addr) / PAGE_SIZE;
if (pte_present(ptent)) {
nr = zap_present_ptes(tlb, vma, pte, ptent, max_nr,
Thanks!
Powered by blists - more mailing lists