[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <9fa26099-1922-4b99-883e-bd5f6c58162a@flourine.local>
Date: Thu, 14 Nov 2024 08:54:46 +0100
From: Daniel Wagner <dwagner@...e.de>
To: Ming Lei <ming.lei@...hat.com>
Cc: Daniel Wagner <wagi@...nel.org>, Jens Axboe <axboe@...nel.dk>,
Bjorn Helgaas <bhelgaas@...gle.com>, "Michael S. Tsirkin" <mst@...hat.com>,
Jason Wang <jasowang@...hat.com>, Xuan Zhuo <xuanzhuo@...ux.alibaba.com>,
Eugenio PĂ©rez <eperezma@...hat.com>, "Martin K. Petersen" <martin.petersen@...cle.com>,
Keith Busch <kbusch@...nel.org>, Christoph Hellwig <hch@....de>, Sagi Grimberg <sagi@...mberg.me>,
John Garry <john.g.garry@...cle.com>, Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Hannes Reinecke <hare@...e.de>, linux-block@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-pci@...r.kernel.org, virtualization@...ts.linux.dev, linux-scsi@...r.kernel.org,
megaraidlinux.pdl@...adcom.com, mpi3mr-linuxdrv.pdl@...adcom.com,
MPT-FusionLinux.pdl@...adcom.com, storagedev@...rochip.com, linux-nvme@...ts.infradead.org
Subject: Re: [PATCH v4 05/10] blk-mq: introduce blk_mq_hctx_map_queues
On Thu, Nov 14, 2024 at 09:58:25AM +0800, Ming Lei wrote:
> > +void blk_mq_hctx_map_queues(struct blk_mq_queue_map *qmap,
>
> Some drivers may not know hctx at all, maybe blk_mq_map_hw_queues()?
I am not really attach to the name, I am fine with renaming it to
blk_mq_map_hw_queues.
> > + if (dev->driver->irq_get_affinity)
> > + irq_get_affinity = dev->driver->irq_get_affinity;
> > + else if (dev->bus->irq_get_affinity)
> > + irq_get_affinity = dev->bus->irq_get_affinity;
>
> It is one generic API, I think both 'dev->driver' and
> 'dev->bus' should be validated here.
What do you have in mind here if we get two masks? What should the
operation be: AND, OR?
This brings up another topic I left out in this series.
blk_mq_map_queues does almost the same thing except it starts with the
mask returned by group_cpus_evenely. If we figure out how this could be
combined in a sane way it's possible to cleanup even a bit more. A bunch
of drivers do
if (i != HCTX_TYPE_POLL && offset)
blk_mq_hctx_map_queues(map, dev->dev, offset);
else
blk_mq_map_queues(map);
IMO it would be nice just to have one blk_mq_map_queues() which handles
this correctly for both cases.
Powered by blists - more mailing lists