[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20241114075822.41614-1-zhangjiao2@cmss.chinamobile.com>
Date: Thu, 14 Nov 2024 15:58:22 +0800
From: zhangjiao2 <zhangjiao2@...s.chinamobile.com>
To: perex@...ex.cz
Cc: tiwai@...e.com,
linux-sound@...r.kernel.org,
linux-kernel@...r.kernel.org,
zhang jiao <zhangjiao2@...s.chinamobile.com>
Subject: [PATCH] ALSA: ump: Fix the wrong format specifier
From: zhang jiao <zhangjiao2@...s.chinamobile.com>
The format specifier of "unsigned int" in snprintf()
should be "%u", not "%d".
Signed-off-by: zhang jiao <zhangjiao2@...s.chinamobile.com>
---
sound/core/ump.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/sound/core/ump.c b/sound/core/ump.c
index ab4932dc499f..5d4dd207e5ab 100644
--- a/sound/core/ump.c
+++ b/sound/core/ump.c
@@ -387,7 +387,7 @@ int snd_ump_block_new(struct snd_ump_endpoint *ump, unsigned int blk,
fb->info.first_group = first_group;
fb->info.num_groups = num_groups;
/* fill the default name, may be overwritten to a better name */
- snprintf(fb->info.name, sizeof(fb->info.name), "Group %d-%d",
+ snprintf(fb->info.name, sizeof(fb->info.name), "Group %u-%u",
first_group + 1, first_group + num_groups);
/* put the entry in the ordered list */
--
2.33.0
Powered by blists - more mailing lists