[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAB9BWhdi2Q3gViCPjYAUYeYktBKR_rc4DN5PqXKvAvA44LDd9g@mail.gmail.com>
Date: Fri, 15 Nov 2024 15:46:45 +0800
From: wenhua lin <wenhua.lin1994@...il.com>
To: Baolin Wang <baolin.wang@...ux.alibaba.com>
Cc: Wenhua Lin <Wenhua.Lin@...soc.com>, Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Jiri Slaby <jirislaby@...nel.org>, Bartosz Golaszewski <brgl@...ev.pl>, Rob Herring <robh@...nel.org>,
Krzysztof Kozlowski <krzk+dt@...nel.org>, Conor Dooley <conor+dt@...nel.org>,
Orson Zhai <orsonzhai@...il.com>, Chunyan Zhang <zhang.lyra@...il.com>,
Cixi Geng <cixi.geng@...ux.dev>, linux-kernel@...r.kernel.org,
linux-serial@...r.kernel.org, devicetree@...r.kernel.org,
Xiongpeng Wu <xiongpeng.wu@...soc.com>, Zhaochen Su <Zhaochen.Su@...soc.com>,
Zhirong Qiu <Zhirong.Qiu@...soc.com>
Subject: Re: [PATCH 1/2] serial: sprd: Add support for sc9632
On Fri, Nov 15, 2024 at 1:47 PM Baolin Wang
<baolin.wang@...ux.alibaba.com> wrote:
>
>
>
> On 2024/11/13 19:05, Wenhua Lin wrote:
> > Due to the platform's new project uart ip upgrade,
> > the new project's timeout interrupt needs to use bit17
> > while other projects' timeout interrupt needs to use
> > bit13, using private data to adapt and be compatible
> > with all projects.
> >
> > Signed-off-by: Wenhua Lin <Wenhua.Lin@...soc.com>
> > ---
> > drivers/tty/serial/sprd_serial.c | 41 ++++++++++++++++++++++++++++----
> > 1 file changed, 36 insertions(+), 5 deletions(-)
> >
> > diff --git a/drivers/tty/serial/sprd_serial.c b/drivers/tty/serial/sprd_serial.c
> > index 3fc54cc02a1f..882580c3cf37 100644
> > --- a/drivers/tty/serial/sprd_serial.c
> > +++ b/drivers/tty/serial/sprd_serial.c
> > @@ -53,10 +53,12 @@
> > #define SPRD_IEN_TX_EMPTY BIT(1)
> > #define SPRD_IEN_BREAK_DETECT BIT(7)
> > #define SPRD_IEN_TIMEOUT BIT(13)
> > +#define SPRD_IEN_DATA_TIMEOUT BIT(17)
>
> I don't know the meaning of 'DATA' in the new macro name. But I have no
> better name now:) Otherwise look good to me.
> Reviewed-by: Baolin Wang <baolin.wang@...ux.alibaba.com>
Hi baolin:
TIMEOUT means only timeout, DATA_TIMEOUT means timeout and fifo is not empty.
Therefore, the macro name is distinguished by adding DATA.
Thanks
Powered by blists - more mailing lists