lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAEf4BzYStc6gaPqHzuP4FhTi4gSCsX65Eq6Zd73p9wVjHisiuQ@mail.gmail.com>
Date: Tue, 26 Nov 2024 13:57:26 -0800
From: Andrii Nakryiko <andrii.nakryiko@...il.com>
To: Thomas Weißschuh <linux@...ssschuh.net>
Cc: Alexei Starovoitov <ast@...nel.org>, Daniel Borkmann <daniel@...earbox.net>, 
	Andrii Nakryiko <andrii@...nel.org>, Martin KaFai Lau <martin.lau@...ux.dev>, 
	Eduard Zingerman <eddyz87@...il.com>, Song Liu <song@...nel.org>, 
	Yonghong Song <yonghong.song@...ux.dev>, John Fastabend <john.fastabend@...il.com>, 
	KP Singh <kpsingh@...nel.org>, Stanislav Fomichev <sdf@...ichev.me>, Hao Luo <haoluo@...gle.com>, 
	Jiri Olsa <jolsa@...nel.org>, bpf@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] btf: Use BIN_ATTR_SIMPLE_RO() to define vmlinux attribute

On Tue, Nov 26, 2024 at 1:42 PM Thomas Weißschuh <linux@...ssschuh.net> wrote:
>
> On 2024-11-26 13:37:26-0800, Andrii Nakryiko wrote:
> > On Fri, Nov 22, 2024 at 4:57 AM Thomas Weißschuh <linux@...ssschuh.net> wrote:
> > >
> > > The usage of the macro allows to remove the custom handler function,
> > > saving some memory. Additionally the code is easier to read.
> > >
> > > Signed-off-by: Thomas Weißschuh <linux@...ssschuh.net>
> > > ---
> > > Something similar can be done to btf_module_read() in kernel/bpf/btf.c.
> > > But doing it here and now would lead to some conflicts with some other
> > > sysfs refactorings I'm doing. It will be part of a future series.
> > > ---
> > >  kernel/bpf/sysfs_btf.c | 21 +++++----------------
> > >  1 file changed, 5 insertions(+), 16 deletions(-)
> > >
> >
> > Nice, let's simplify. But why change the name to generic "vmlinux" if
> > it's actually btf_vmlinux? Can we keep the original btf-specific name?
>
> The file in sysfs is named "vmlinux", /sys/kernel/btf/vmlinux.
> This is what needs to be passed to the macro, it will name both the
> variable and the file after it.
>
> One alternative would be to use __BIN_ATTR_SIMPLE_RO() which allows a
> custom name.
>

Probably not worth it, ok, I'm fine with the name change, it's a local
name anyways.

> >
> > pw-bot: cr
> >
> > > diff --git a/kernel/bpf/sysfs_btf.c b/kernel/bpf/sysfs_btf.c
> > > index fedb54c94cdb830a4890d33677dcc5a6e236c13f..a24381f933d0b80b11116d05463c35e9fa66acb1 100644
> > > --- a/kernel/bpf/sysfs_btf.c
> > > +++ b/kernel/bpf/sysfs_btf.c
> > > @@ -12,34 +12,23 @@
> > >  extern char __start_BTF[];
> > >  extern char __stop_BTF[];
> > >
> > > -static ssize_t
> > > -btf_vmlinux_read(struct file *file, struct kobject *kobj,
> > > -                struct bin_attribute *bin_attr,
> > > -                char *buf, loff_t off, size_t len)
> > > -{
> > > -       memcpy(buf, __start_BTF + off, len);
> > > -       return len;
> > > -}
> > > -
> > > -static struct bin_attribute bin_attr_btf_vmlinux __ro_after_init = {
> > > -       .attr = { .name = "vmlinux", .mode = 0444, },
> > > -       .read = btf_vmlinux_read,
> > > -};
> > > +static __ro_after_init BIN_ATTR_SIMPLE_RO(vmlinux);
> > >
> > >  struct kobject *btf_kobj;
> > >
> > >  static int __init btf_vmlinux_init(void)
> > >  {
> > > -       bin_attr_btf_vmlinux.size = __stop_BTF - __start_BTF;
> > > +       bin_attr_vmlinux.private = __start_BTF;
> > > +       bin_attr_vmlinux.size = __stop_BTF - __start_BTF;
> > >
> > > -       if (bin_attr_btf_vmlinux.size == 0)
> > > +       if (bin_attr_vmlinux.size == 0)
> > >                 return 0;
> > >
> > >         btf_kobj = kobject_create_and_add("btf", kernel_kobj);
> > >         if (!btf_kobj)
> > >                 return -ENOMEM;
> > >
> > > -       return sysfs_create_bin_file(btf_kobj, &bin_attr_btf_vmlinux);
> > > +       return sysfs_create_bin_file(btf_kobj, &bin_attr_vmlinux);
> > >  }
> > >
> > >  subsys_initcall(btf_vmlinux_init);
> > >
> > > ---
> > > base-commit: 28eb75e178d389d325f1666e422bc13bbbb9804c
> > > change-id: 20241122-sysfs-const-bin_attr-bpf-737286bb9f27
> > >
> > > Best regards,
> > > --
> > > Thomas Weißschuh <linux@...ssschuh.net>
> > >

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ