[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20241202075545.3648096-2-davidgow@google.com>
Date: Mon, 2 Dec 2024 15:55:38 +0800
From: David Gow <davidgow@...gle.com>
To: Andrew Morton <akpm@...ux-foundation.org>, Shuah Khan <skhan@...uxfoundation.org>,
Rae Moar <rmoar@...gle.com>, Kees Cook <kees@...nel.org>,
Geert Uytterhoeven <geert@...ux-m68k.org>
Cc: Luis Felipe Hernandez <luis.hernandez093@...il.com>, linux-kselftest@...r.kernel.org,
kunit-dev@...glegroups.com, linux-kernel@...r.kernel.org,
Stephen Rothwell <sfr@...b.auug.org.au>, Andy Shevchenko <andy@...nel.org>,
Brendan Higgins <brendan.higgins@...ux.dev>, Nicolas Pitre <npitre@...libre.com>,
David Gow <davidgow@...gle.com>
Subject: [PATCH v2 1/6] lib: math: Move kunit tests into tests/ subdir
From: Luis Felipe Hernandez <luis.hernandez093@...il.com>
This patch is a follow-up task from a discussion stemming from point 3
in a recent patch introducing the int_pow kunit test [1] and
documentation regarding kunit test style and nomenclature [2].
Colocate all kunit test suites in lib/math/tests/ and
follow recommended naming convention for files <suite>_kunit.c
and kconfig entries CONFIG_<name>_KUNIT_TEST.
Link: https://lore.kernel.org/all/CABVgOS=-vh5TqHFCq_jo=ffq8v_nGgr6JsPnOZag3e6+19ysxQ@mail.gmail.com/ [1]
Link: https://docs.kernel.org/dev-tools/kunit/style.html [2]
Signed-off-by: Luis Felipe Hernandez <luis.hernandez093@...il.com>
Acked-by: Nicolas Pitre <npitre@...libre.com>
[Rebased on top of v6.13-rc1, removed non-kunit tests]
Signed-off-by: David Gow <davidgow@...gle.com>
---
lib/Kconfig.debug | 2 +-
lib/math/Makefile | 4 ++--
lib/math/tests/Makefile | 3 ++-
lib/math/{rational-test.c => tests/rational_kunit.c} | 0
4 files changed, 5 insertions(+), 4 deletions(-)
rename lib/math/{rational-test.c => tests/rational_kunit.c} (100%)
diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug
index f3d723705879..7b90948666bf 100644
--- a/lib/Kconfig.debug
+++ b/lib/Kconfig.debug
@@ -3145,7 +3145,7 @@ config TEST_OBJPOOL
If unsure, say N.
-config INT_POW_TEST
+config INT_POW_KUNIT_TEST
tristate "Integer exponentiation (int_pow) test" if !KUNIT_ALL_TESTS
depends on KUNIT
default KUNIT_ALL_TESTS
diff --git a/lib/math/Makefile b/lib/math/Makefile
index 3ef11305f8d2..d1caba23baa0 100644
--- a/lib/math/Makefile
+++ b/lib/math/Makefile
@@ -5,7 +5,7 @@ obj-$(CONFIG_CORDIC) += cordic.o
obj-$(CONFIG_PRIME_NUMBERS) += prime_numbers.o
obj-$(CONFIG_RATIONAL) += rational.o
-obj-$(CONFIG_INT_POW_TEST) += tests/int_pow_kunit.o
obj-$(CONFIG_TEST_DIV64) += test_div64.o
obj-$(CONFIG_TEST_MULDIV64) += test_mul_u64_u64_div_u64.o
-obj-$(CONFIG_RATIONAL_KUNIT_TEST) += rational-test.o
+
+obj-y += tests/
diff --git a/lib/math/tests/Makefile b/lib/math/tests/Makefile
index 6a169123320a..8ce8040e00c5 100644
--- a/lib/math/tests/Makefile
+++ b/lib/math/tests/Makefile
@@ -1,3 +1,4 @@
# SPDX-License-Identifier: GPL-2.0-only
-obj-$(CONFIG_INT_POW_TEST) += int_pow_kunit.o
+obj-$(CONFIG_INT_POW_KUNIT_TEST) += int_pow_kunit.o
+obj-$(CONFIG_RATIONAL_KUNIT_TEST) += rational_kunit.o
diff --git a/lib/math/rational-test.c b/lib/math/tests/rational_kunit.c
similarity index 100%
rename from lib/math/rational-test.c
rename to lib/math/tests/rational_kunit.c
--
2.47.0.338.g60cca15819-goog
Powered by blists - more mailing lists