[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20241203180710.0000204d@huawei.com>
Date: Tue, 3 Dec 2024 18:07:10 +0000
From: Jonathan Cameron <Jonathan.Cameron@...wei.com>
To: Paul Barker <paul.barker.ct@...renesas.com>
CC: Claudiu <claudiu.beznea@...on.dev>,
<prabhakar.mahadev-lad.rj@...renesas.com>, <jic23@...nel.org>,
<lars@...afoo.de>, <robh@...nel.org>, <krzk+dt@...nel.org>,
<conor+dt@...nel.org>, <geert+renesas@...der.be>, <magnus.damm@...il.com>,
<mturquette@...libre.com>, <sboyd@...nel.org>, <p.zabel@...gutronix.de>,
<linux-iio@...r.kernel.org>, <linux-renesas-soc@...r.kernel.org>,
<devicetree@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<linux-clk@...r.kernel.org>, Claudiu Beznea
<claudiu.beznea.uj@...renesas.com>
Subject: Re: [PATCH 06/14] iio: adc: rzg2l_adc: Simplify the locking scheme
in rzg2l_adc_read_raw()
On Tue, 3 Dec 2024 13:03:29 +0000
Paul Barker <paul.barker.ct@...renesas.com> wrote:
> Hi Claudiu,
>
> On 03/12/2024 11:13, Claudiu wrote:
> > From: Claudiu Beznea <claudiu.beznea.uj@...renesas.com>
> >
> > Simplify the locking scheme in rzg2l_adc_read_raw() by saving the converted
> > value only if the rzg2l_adc_conversion() returns success. The approach
> > simplifies the addition of thermal sensor support (that will be done in the
> > next commits). The downside is that the ret variable need to be checked
> > twice.
> >
> > Signed-off-by: Claudiu Beznea <claudiu.beznea.uj@...renesas.com>
> > ---
> > drivers/iio/adc/rzg2l_adc.c | 9 +++------
> > 1 file changed, 3 insertions(+), 6 deletions(-)
> >
> > diff --git a/drivers/iio/adc/rzg2l_adc.c b/drivers/iio/adc/rzg2l_adc.c
> > index 62932f9295b6..eed2944bd98d 100644
> > --- a/drivers/iio/adc/rzg2l_adc.c
> > +++ b/drivers/iio/adc/rzg2l_adc.c
> > @@ -227,14 +227,11 @@ static int rzg2l_adc_read_raw(struct iio_dev *indio_dev,
> > mutex_lock(&adc->lock);
> > ch = chan->channel & RZG2L_ADC_CHN_MASK;
> > ret = rzg2l_adc_conversion(indio_dev, adc, ch);
> > - if (ret) {
> > - mutex_unlock(&adc->lock);
> > - return ret;
> > - }
> > - *val = adc->last_val[ch];
> > + if (!ret)
> > + *val = adc->last_val[ch];
> > mutex_unlock(&adc->lock);
> >
> > - return IIO_VAL_INT;
> > + return ret ? ret : IIO_VAL_INT;
>
> It would be maybe slightly neater to use:
>
> if (!ret) {
> *val = adc->last_val[ch];
> ret = IIO_VAL_INT;
> }
> mutex_unlock(&adc->lock);
>
> return ret;
>
Better I think to use {} for scope and
guard(mutex)()
...
if (ret)
return ret;
*val = adc->last_val[ch];
Where possible keeping the error path as the out of line element is
easier to follow on basis that is most common pattern so what a reviewers
eye is 'trained' to see.
Jonathan
> Thanks,
>
Powered by blists - more mailing lists