[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <cover.1733504943.git.mchehab+huawei@kernel.org>
Date: Fri, 6 Dec 2024 18:12:22 +0100
From: Mauro Carvalho Chehab <mchehab+huawei@...nel.org>
To: "Michael S . Tsirkin" <mst@...hat.com>
Cc: Jonathan Cameron <Jonathan.Cameron@...wei.com>,
Shiju Jose <shiju.jose@...wei.com>,
Mauro Carvalho Chehab <mchehab+huawei@...nel.org>,
Philippe Mathieu-Daudé <philmd@...aro.org>,
Ani Sinha <anisinha@...hat.com>,
Cleber Rosa <crosa@...hat.com>,
Dongjiu Geng <gengdongjiu1@...il.com>,
Eduardo Habkost <eduardo@...kost.net>,
Eric Blake <eblake@...hat.com>,
Igor Mammedov <imammedo@...hat.com>,
John Snow <jsnow@...hat.com>,
Marcel Apfelbaum <marcel.apfelbaum@...il.com>,
Markus Armbruster <armbru@...hat.com>,
Michael Roth <michael.roth@....com>,
Paolo Bonzini <pbonzini@...hat.com>,
Peter Maydell <peter.maydell@...aro.org>,
Shannon Zhao <shannon.zhaosl@...il.com>,
Yanan Wang <wangyanan55@...wei.com>,
Zhao Liu <zhao1.liu@...el.com>,
kvm@...r.kernel.org,
linux-kernel@...r.kernel.org,
qemu-arm@...gnu.org,
qemu-devel@...gnu.org
Subject: [PATCH 00/31] Prepare GHES driver to support error injection
Hi Michael,
Could you please merge this series for ACPI stuff? All patches were already
reviewed by Igor. The changes against v4 are just on some patch descriptions,
plus the addition of Reviewed-by. No Code changes.
Thanks,
Mauro
-
During the development of a patch series meant to allow GHESv2 error injections,
it was requested a change on how CPER offsets are calculated, by adding a new
BIOS pointer and reworking the GHES logic. See:
https://lore.kernel.org/qemu-devel/cover.1726293808.git.mchehab+huawei@kernel.org/
Such change ended being a big patch, so several intermediate steps are needed,
together with several cleanups and renames.
As agreed duing v10 review, I'll be splitting the big patch series into separate pull
requests, starting with the cleanup series. This is the first patch set, containing
only such preparation patches.
The next series will contain the shift to use offsets from the location of the
HEST table, together with a migration logic to make it compatible with 9.1.
---
v5:
- some changes at patches description and added some R-B;
- no changes at the code.
v4:
- merged a patch renaming the function which calculate offsets to:
get_hw_error_offsets(), to avoid the need of such change at the next
patch series;
- removed a functional change at the logic which makes
the GHES record generation more generic;
- a couple of trivial changes on patch descriptions and line break cleanups.
v3:
- improved some patch descriptions;
- some patches got reordered to better reflect the changes;
- patch v2 08/15: acpi/ghes: Prepare to support multiple sources on ghes
was split on two patches. The first one is in this cleanup series:
acpi/ghes: Change ghes fill logic to work with only one source
contains just the simplification logic. The actual preparation will
be moved to this series:
https://lore.kernel.org/qemu-devel/cover.1727782588.git.mchehab+huawei@kernel.org/
v2:
- some indentation fixes;
- some description improvements;
- fixed a badly-solved merge conflict that ended renaming a parameter.
Mauro Carvalho Chehab (31):
acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED
acpi/ghes: simplify acpi_ghes_record_errors() code
acpi/ghes: simplify the per-arch caller to build HEST table
acpi/ghes: better handle source_id and notification
acpi/ghes: Fix acpi_ghes_record_errors() argument
acpi/ghes: Remove a duplicated out of bounds check
acpi/ghes: Change the type for source_id
acpi/ghes: don't check if physical_address is not zero
acpi/ghes: make the GHES record generation more generic
acpi/ghes: better name GHES memory error function
acpi/ghes: don't crash QEMU if ghes GED is not found
acpi/ghes: rename etc/hardware_error file macros
acpi/ghes: better name the offset of the hardware error firmware
acpi/ghes: Prepare to support multiple sources on ghes
acpi/ghes: add a firmware file with HEST address
acpi/ghes: Use HEST table offsets when preparing GHES records
acpi/generic_event_device: Update GHES migration to cover hest addr
acpi/generic_event_device: add logic to detect if HEST addr is
available
acpi/ghes: add a notifier to notify when error data is ready
acpi/generic_event_device: add an APEI error device
arm/virt: Wire up a GED error device for ACPI / GHES
qapi/acpi-hest: add an interface to do generic CPER error injection
scripts/ghes_inject: add a script to generate GHES error inject
target/arm: add an experimental mpidr arm cpu property object
scripts/arm_processor_error.py: retrieve mpidr if not filled
acpi/ghes: move offset calculus to a separate function
DEBUG
acpi/ghes: Change ghes fill logic to work with only one source
HACK: use GPIO as source ID for virt-9.1 machines
docs: acpi_hest_ghes: fix documentation for CPER size
FIXME: acpi/ghes: properly set data record size
MAINTAINERS | 10 +
docs/specs/acpi_hest_ghes.rst | 6 +-
hw/acpi/Kconfig | 5 +
hw/acpi/aml-build.c | 10 +
hw/acpi/generic_event_device.c | 42 +-
hw/acpi/ghes-stub.c | 2 +-
hw/acpi/ghes.c | 391 ++++++++++----
hw/acpi/ghes_cper.c | 32 ++
hw/acpi/ghes_cper_stub.c | 19 +
hw/acpi/meson.build | 2 +
hw/arm/virt-acpi-build.c | 36 +-
hw/arm/virt.c | 19 +-
hw/core/machine.c | 2 +
include/hw/acpi/acpi_dev_interface.h | 1 +
include/hw/acpi/aml-build.h | 2 +
include/hw/acpi/generic_event_device.h | 1 +
include/hw/acpi/ghes.h | 39 +-
include/hw/arm/virt.h | 2 +
qapi/acpi-hest.json | 35 ++
qapi/meson.build | 1 +
qapi/qapi-schema.json | 1 +
scripts/arm_processor_error.py | 390 ++++++++++++++
scripts/ghes_inject.py | 51 ++
scripts/qmp_helper.py | 702 +++++++++++++++++++++++++
target/arm/cpu.c | 1 +
target/arm/cpu.h | 1 +
target/arm/helper.c | 10 +-
target/arm/kvm.c | 2 +-
28 files changed, 1678 insertions(+), 137 deletions(-)
create mode 100644 hw/acpi/ghes_cper.c
create mode 100644 hw/acpi/ghes_cper_stub.c
create mode 100644 qapi/acpi-hest.json
create mode 100644 scripts/arm_processor_error.py
create mode 100755 scripts/ghes_inject.py
create mode 100644 scripts/qmp_helper.py
--
2.47.1
Powered by blists - more mailing lists