[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Z1KpWenJGqhjtNL9@V92F7Y9K0C.lan>
Date: Thu, 5 Dec 2024 23:35:53 -0800
From: Dennis Zhou <dennis@...nel.org>
To: Uros Bizjak <ubizjak@...il.com>
Cc: x86@...nel.org, linux-mm@...ck.org, linux-kernel@...r.kernel.org,
linux-bcachefs@...r.kernel.org, linux-arch@...r.kernel.org,
netdev@...r.kernel.org, Nadav Amit <nadav.amit@...il.com>,
Arnd Bergmann <arnd@...db.de>, Thomas Gleixner <tglx@...utronix.de>,
Dennis Zhou <dennis@...nel.org>, Tejun Heo <tj@...nel.org>,
Christoph Lameter <cl@...ux.com>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Andy Lutomirski <luto@...nel.org>, Ingo Molnar <mingo@...nel.org>,
Brian Gerst <brgerst@...il.com>, "H. Peter Anvin" <hpa@...or.com>,
Peter Zijlstra <peterz@...radead.org>
Subject: Re: [PATCH v2 5/6] percpu: Repurpose __percpu tag as a named address
space qualifier
Hi Uros,
On Thu, Dec 05, 2024 at 04:40:55PM +0100, Uros Bizjak wrote:
> The patch introduces per_cpu_qual define and repurposes __percpu
> tag as a named address space qualifier using the new define.
>
> Arches can now conditionally define __per_cpu_qual as their
> named address space qualifier for percpu variables.
>
> Signed-off-by: Uros Bizjak <ubizjak@...il.com>
> Acked-by: Nadav Amit <nadav.amit@...il.com>
> Cc: Arnd Bergmann <arnd@...db.de>
> Cc: Thomas Gleixner <tglx@...utronix.de>
> Cc: Dennis Zhou <dennis@...nel.org>
> Cc: Tejun Heo <tj@...nel.org>
> Cc: Christoph Lameter <cl@...ux.com>
> Cc: Linus Torvalds <torvalds@...ux-foundation.org>
> Cc: Andy Lutomirski <luto@...nel.org>
> Cc: Ingo Molnar <mingo@...nel.org>
> Cc: Brian Gerst <brgerst@...il.com>
> Cc: "H. Peter Anvin" <hpa@...or.com>
> Cc: Peter Zijlstra <peterz@...radead.org>
> ---
> include/asm-generic/percpu.h | 15 +++++++++++++++
> include/linux/compiler_types.h | 2 +-
> 2 files changed, 16 insertions(+), 1 deletion(-)
>
> diff --git a/include/asm-generic/percpu.h b/include/asm-generic/percpu.h
> index 50597b975a49..3b93b168faa1 100644
> --- a/include/asm-generic/percpu.h
> +++ b/include/asm-generic/percpu.h
> @@ -6,6 +6,21 @@
> #include <linux/threads.h>
> #include <linux/percpu-defs.h>
>
> +/*
> + * per_cpu_qual is the qualifier for the percpu named address space.
> + *
> + * Most arches use generic named address space for percpu variables but
> + * some arches define percpu variables in different named address space
> + * (on the x86 arch, percpu variable may be declared as being relative
> + * to the %fs or %gs segments using __seg_fs or __seg_gs named address
> + * space qualifier).
> + */
> +#ifdef __per_cpu_qual
I read through the series and I think my only nit would be here. Can we
name this __percpu_qual? My thoughts are that it keeps it consistent
with the old address space identifier and largely most of the core
percpu stuff is defined with percpu as the naming scheme.
> +# define per_cpu_qual __per_cpu_qual
> +#else
> +# define per_cpu_qual
> +#endif
> +
> #ifdef CONFIG_SMP
>
> /*
> diff --git a/include/linux/compiler_types.h b/include/linux/compiler_types.h
> index 981cc3d7e3aa..877fe0c43c5d 100644
> --- a/include/linux/compiler_types.h
> +++ b/include/linux/compiler_types.h
> @@ -57,7 +57,7 @@ static inline void __chk_io_ptr(const volatile void __iomem *ptr) { }
> # define __user BTF_TYPE_TAG(user)
> # endif
> # define __iomem
> -# define __percpu BTF_TYPE_TAG(percpu)
> +# define __percpu per_cpu_qual BTF_TYPE_TAG(percpu)
> # define __rcu BTF_TYPE_TAG(rcu)
>
> # define __chk_user_ptr(x) (void)0
> --
> 2.42.0
>
Thanks,
Dennis
Powered by blists - more mailing lists