[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20241216151400.00006242@huawei.com>
Date: Mon, 16 Dec 2024 15:14:00 +0000
From: Jonathan Cameron <Jonathan.Cameron@...wei.com>
To: Zijun Hu <zijun_hu@...oud.com>
CC: Greg Kroah-Hartman <gregkh@...uxfoundation.org>, "Rafael J. Wysocki"
<rafael@...nel.org>, Tejun Heo <tj@...nel.org>, Josef Bacik
<josef@...icpanda.com>, Jens Axboe <axboe@...nel.dk>, Boris Burkov
<boris@....io>, Davidlohr Bueso <dave@...olabs.net>, Dave Jiang
<dave.jiang@...el.com>, Alison Schofield <alison.schofield@...el.com>, Vishal
Verma <vishal.l.verma@...el.com>, Ira Weiny <ira.weiny@...el.com>, Dan
Williams <dan.j.williams@...el.com>, <linux-kernel@...r.kernel.org>,
<cgroups@...r.kernel.org>, <linux-block@...r.kernel.org>,
<linux-cxl@...r.kernel.org>, Zijun Hu <quic_zijuhu@...cinc.com>
Subject: Re: [PATCH v3 3/9] driver core: bus: Move true expression out of if
condition in API bus_find_device()
On Thu, 12 Dec 2024 21:38:39 +0800
Zijun Hu <zijun_hu@...oud.com> wrote:
> From: Zijun Hu <quic_zijuhu@...cinc.com>
>
> For bus_find_device(), get_device() in the if condition always returns
> true, move it to if body to make the API's logic more clearer.
>
> Signed-off-by: Zijun Hu <quic_zijuhu@...cinc.com>
I agree this is easier to read and the reasoning is sound.
Reviewed-by: Jonathan Cameron <Jonathan.Cameron@...wei.com>
> ---
> drivers/base/bus.c | 7 +++++--
> 1 file changed, 5 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/base/bus.c b/drivers/base/bus.c
> index 657c93c38b0dc2a2247e5f482fadd3a9376a58e8..73a56f376d3a05962ce0931a2fe8b4d8839157f2 100644
> --- a/drivers/base/bus.c
> +++ b/drivers/base/bus.c
> @@ -402,9 +402,12 @@ struct device *bus_find_device(const struct bus_type *bus,
>
> klist_iter_init_node(&sp->klist_devices, &i,
> (start ? &start->p->knode_bus : NULL));
> - while ((dev = next_device(&i)))
> - if (match(dev, data) && get_device(dev))
> + while ((dev = next_device(&i))) {
> + if (match(dev, data)) {
> + get_device(dev);
> break;
> + }
> + }
> klist_iter_exit(&i);
> subsys_put(sp);
> return dev;
>
Powered by blists - more mailing lists