[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <9cbdbad3-9ee8-42db-bd0d-b31986a07731@linux.microsoft.com>
Date: Fri, 27 Dec 2024 10:42:43 -0800
From: Easwar Hariharan <eahariha@...ux.microsoft.com>
To: Roman Kisel <romank@...ux.microsoft.com>
Cc: hpa@...or.com, kys@...rosoft.com, bp@...en8.de,
dave.hansen@...ux.intel.com, decui@...rosoft.com, haiyangz@...rosoft.com,
mingo@...hat.com, mhklinux@...look.com, nunodasneves@...ux.microsoft.com,
tglx@...utronix.de, tiala@...rosoft.com, wei.liu@...nel.org,
linux-hyperv@...r.kernel.org, linux-kernel@...r.kernel.org, x86@...nel.org,
eahariha@...ux.microsoft.com, apais@...rosoft.com, benhill@...rosoft.com,
ssengar@...rosoft.com, sunilmut@...rosoft.com, vdso@...bites.dev
Subject: Re: [PATCH v4 0/5] hyperv: Fixes for get_vtl(),
hv_vtl_apicid_to_vp_id()
On 12/27/2024 10:31 AM, Roman Kisel wrote:
> The get_vtl(void) function
>
> * has got one bug when the code started using a wrong pointer type after
> refactoring, and also
> * the both function in question don't adhere to the requirements of
> the Hypervisor Top-Level Funactional Specification[1, 2] as the code overlaps
> the input and output areas for a hypercall.
>
> The first issue leads to a wrong 100% reproducible computation due to reading
> a byte worth of data at a wrong offset. That in turn leads to using a nonsensical
> value ("fortunately", could catch it easily!) for the current VTL when initiating
> VMBus communications. As a repercussion from that, the system wouldn't boot. The
> fix is straightforward: use the correct pointer type.
>
> The second issue doesn't seem to lead to any reproducible breakage just yet. It is
> fixed with using the output hypercall pages allocated per-CPU, and that isn't the
> only or the most obvious choice so let me elaborate why that fix appears to be the
> best one in my opinion out of the options I could conceive of.
>
> The approach chosen for fixing the second issue makes two things shine through:
>
> * these functions just get a vCPU register, no special treatment needs to be
> involved,
> * VTLs and dom0 can and should share code as both exist to provide services to
> a guest(s), be that from within the partition or from outside of it.
>
> The projected benefits include replacing the functions in question with a future
> `hv_get_vp_registers` one shared between dom0 and VTLs to allow for a better test
> coverage.
>
> I have validated the fixes by booting the fixed kernel in VTL2 up using OpenVMM and
> OpenHCL[3, 4].
>
> [1] https://learn.microsoft.com/en-us/virtualization/hyper-v-on-windows/tlfs/hypercall-interface
> [2] https://github.com/MicrosoftDocs/Virtualization-Documentation/tree/main/tlfs
> [3] https://openvmm.dev/guide/user_guide/openhcl.html
> [4] https://github.com/microsoft/OpenVMM
>
> [v4]
> - Wrapped DECLARE_FLEX_ARRAY into a struct and added one more
> member as the documentation requires,
> - Removed superfluous type coercion,
> - Fixed tags,
> - Rebased onto the latest hyperv-next branch.
>
> [v3]: https://lore.kernel.org/lkml/20241226213110.899497-1-romank@linux.microsoft.com/
> - Added a fix for hv_vtl_apicid_to_vp_id(),
> - Split out the patch for enabling the hypercall output page,
> - Updated the title of the patch series,
>
> [v2]: https://lore.kernel.org/lkml/20241226203050.800524-1-romank@linux.microsoft.com/
> - Used the suggestions to define an additional structure to improve code readability,
> - Split out the patch with that definition.
>
> [v1]: https://lore.kernel.org/lkml/20241218205421.319969-1-romank@linux.microsoft.com/
>
> Roman Kisel (5):
> hyperv: Define struct hv_output_get_vp_registers
> hyperv: Fix pointer type in get_vtl(void)
> hyperv: Enable the hypercall output page for the VTL mode
> hyperv: Do not overlap the hvcall IO areas in get_vtl()
> hyperv: Do not overlap the hvcall IO areas in hv_vtl_apicid_to_vp_id()
>
> arch/x86/hyperv/hv_init.c | 6 ++--
> arch/x86/hyperv/hv_vtl.c | 2 +-
> drivers/hv/hv_common.c | 6 ++--
> include/hyperv/hvgdk_mini.h | 65 +++++++++++++++++++++++++++++++++++--
> 4 files changed, 70 insertions(+), 9 deletions(-)
>
>
> base-commit: 26e1b813fcd02984b1cac5f3decdf4b0bb56fe02
Thank you for the persistence!
For the series,
Reviewed-by: Easwar Hariharan <eahariha@...ux.microsoft.com>
Powered by blists - more mailing lists