[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHB1NahrqxSXXCy-BMpTk8+3ZwrAZgWs1Ev5AtcQe3L2Mf+bSg@mail.gmail.com>
Date: Tue, 7 Jan 2025 10:57:05 +0800
From: Julian Sun <sunjunchao2870@...il.com>
To: Jan Kara <jack@...e.cz>
Cc: linux-ext4@...r.kernel.org, linux-kernel@...r.kernel.org, tytso@....edu,
adilger.kernel@...ger.ca, boyu.mt@...bao.com, tm@....ma
Subject: Re: [PATCH 4/7] ext4: Introduce a new helper function ext4_generic_write_inline_data()
Jan Kara <jack@...e.cz> 于2025年1月6日周一 23:35写道:
>
> On Fri 20-12-24 23:16:22, Julian Sun wrote:
> > A new function, ext4_generic_write_inline_data(), is introduced
> > to provide a generic implementation of the common logic found in
> > ext4_da_write_inline_data_begin() and ext4_try_to_write_inline_data().
> >
> > This function will be utilized in the subsequent two patches.
> >
> > Signed-off-by: Julian Sun <sunjunchao2870@...il.com>
>
> Looks good, just one style nit below. Feel free to add:
>
> Reviewed-by: Jan Kara <jack@...e.cz>
>
> ...
> > + *foliop = folio;
> > + up_read(&EXT4_I(inode)->xattr_sem);
> > + brelse(iloc.bh);
> > + return 1;
>
> Here I'd suggest empty line for better readability.
I will fix it in the next version. thanks!
>
> > +out_release_folio:
> > + up_read(&EXT4_I(inode)->xattr_sem);
> > + folio_unlock(folio);
> > + folio_put(folio);
> > +out_stop_journal:
> > + ext4_journal_stop(handle);
> > +out_release_bh:
> > + brelse(iloc.bh);
> > + return ret;
> > +}
> > +
>
> Honza
> --
> Jan Kara <jack@...e.com>
> SUSE Labs, CR
--
Julian Sun <sunjunchao2870@...il.com>
Powered by blists - more mailing lists