[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <m2septp9dz.fsf@posteo.net>
Date: Wed, 08 Jan 2025 16:18:00 +0000
From: Charalampos Mitrodimas <charmitro@...teo.net>
To: Mitchell Levy <levymitchell0@...il.com>
Cc: "Christoph Lameter (Ampere)" <cl@...two.org>, Miguel Ojeda
<ojeda@...nel.org>, Alex Gaynor <alex.gaynor@...il.com>, Boqun Feng
<boqun.feng@...il.com>, Gary Guo <gary@...yguo.net>, Björn Roy Baron
<bjorn3_gh@...tonmail.com>, Benno Lossin <benno.lossin@...ton.me>,
Andreas Hindborg <a.hindborg@...nel.org>, Alice Ryhl
<aliceryhl@...gle.com>, Trevor Gross <tmgross@...ch.edu>, Andrew Morton
<akpm@...ux-foundation.org>, Dennis Zhou <dennis@...nel.org>, Tejun Heo
<tj@...nel.org>, linux-kernel@...r.kernel.org,
rust-for-linux@...r.kernel.org, linux-mm@...ck.org
Subject: Re: [PATCH RFC 3/3] rust: percpu: add a rust per-CPU variable test
Mitchell Levy <levymitchell0@...il.com> writes:
> On Sun, Jan 05, 2025 at 01:01:43PM +0000, Charalampos Mitrodimas wrote:
>> "Christoph Lameter (Ampere)" <cl@...two.org> writes:
>>
>> > On Thu, 19 Dec 2024, Mitchell Levy wrote:
>> >
>> >> + let mut native: i64 = 0;
>> >> + let mut pcpu: PerCpuRef<i64> = unsafe { unsafe_get_per_cpu_ref!(PERCPU, CpuGuard::new()) };
>> >
>> > A bit complex.
>>
>> I agree with this, maybe a helper function would suffise? Something in
>> terms of,
>> unsafe fn get_per_cpu<T>(var: &PerCpuVariable<T>) -> PerCpuRef<T> {
>> unsafe_get_per_cpu_ref!(var, CpuGuard::new())
>> }
>
> I'm certainly open to adding such a helper. Is the main concern here the
> unwieldy name? Generally, I prefer to keep modifications to global state
> (disabling preemption via CpuGuard::new()) as explicit as possible, but
> if there's consensus to the contrary, I'm happy to roll it into the
> macro/a helper function.
Yes, in my opinion, the macro name is indeed complex. You're right about
keeping modifications as explicit as possible. A helper wouldn’t be
necessary if the macro name were simpler.
Is adding "unsafe_" to a macro that is unsafe a standard practice? Maybe
we can remove it from the macro name. Documentation is enough IMO.
>
>> >
>> >> + native += -1;
>> >> + *pcpu += -1;
>> >> + assert!(native == *pcpu && native == -1);
>> >> +
>> >> + native += 1;
>> >> + *pcpu += 1;
>> >> + assert!(native == *pcpu && native == 0);
>> >> +
>> >
>> > That's pretty straightforward..... But is there no symbolic access to the
>> > per cpu namespace? How would you access the kernel per cpu variables
>> > defined in C?
>> >
>> > How do you go about using per cpu atomics like
>> >
>> > this_cpu_inc(nr_dentry_unused);
Powered by blists - more mailing lists