[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <87frltcgpj.fsf@oracle.com>
Date: Wed, 08 Jan 2025 10:18:16 -0800
From: Ankur Arora <ankur.a.arora@...cle.com>
To: paulmck@...nel.org
Cc: Ankur Arora <ankur.a.arora@...cle.com>, linux-kernel@...r.kernel.org,
peterz@...radead.org, tglx@...utronix.de, mingo@...nel.org,
bigeasy@...utronix.de, juri.lelli@...hat.com,
vincent.guittot@...aro.org, dietmar.eggemann@....com,
rostedt@...dmis.org, bsegall@...gle.com, mgorman@...e.de,
vschneid@...hat.com, frederic@...nel.org, efault@....de,
sshegde@...ux.ibm.com, boris.ostrovsky@...cle.com
Subject: Re: [PATCH v3 0/7] RCU changes for PREEMPT_LAZY
Paul E. McKenney <paulmck@...nel.org> writes:
> On Thu, Dec 12, 2024 at 08:06:51PM -0800, Ankur Arora wrote:
>> This series adds RCU bits for lazy preemption.
>>
>> The problem addressed is that pre-PREEMPT_LAZY, PREEMPTION=y implied
>> PREEMPT_RCU=y. With PREEMPT_LAZY, that's no longer true.
>>
>> That's because PREEMPT_RCU makes some trade-offs to optimize for
>> latency as opposed to throughput, and configurations with limited
>> preemption might prefer the stronger forward-progress guarantees of
>> PREEMPT_RCU=n.
>>
>> Accordingly, with standalone PREEMPT_LAZY (much like PREEMPT_NONE,
>> PREEMPT_VOLUNTARY) we want to use PREEMPT_RCU=n. And, when used in
>> conjunction with PREEMPT_DYNAMIC, we continue to use PREEMPT_RCU=y.
>>
>> Patches 1-3 are cleanup patches:
>> "rcu: fix header guard for rcu_all_qs()"
>> "rcu: rename PREEMPT_AUTO to PREEMPT_LAZY"
>> "sched: update __cond_resched comment about RCU quiescent states"
>>
>> Patch 4,
>> "rcu: handle unstable rdp in rcu_read_unlock_strict()"
>>
>> handles a latent RCU bug rcu_report_qs_rdp() could be called with
>> an unstable rdp.
>>
>> Patches 5 and 6,
>> "rcu: handle quiescent states for PREEMPT_RCU=n, PREEMPT_COUNT=y"
>> "osnoise: provide quiescent states"
>>
>> handle quiescent states for the (PREEMPT_LAZY=y, PREEMPT_RCU=n)
>> configuration.
>>
>> And, finally patch 7, "rcu: limit PREEMPT_RCU configurations",
>> explicitly limits PREEMPT_RCU=y to the PREEMPT_DYNAMIC or the latency
>> oriented models.
>
> Pulled into my -rcu tree for further review and testing, with initial
> tests passing. Apologies for the delay!
Great. Thanks Paul!
Ankur
>> Changelog:
>>
>> v3:
>> - moved patch-3 to be the last one in the series (suggested by Sebastian)
>> - added "rcu: handle unstable rdp in rcu_read_unlock_strict()"
>> (suggested by Frederic Weisbecker).
>> - switched to a more robust check in rcu_flavor_sched_clock_irq()
>> (suggested by Frederic Weisbecker).
>> - simplified check in osnoise (suggested by Frederic Weisbecker).
>> - dropped an unrelated scheduler patch.
>>
>> v2:
>> - fixup incorrect usage of tif_need_resched_lazy() (comment from
>> from Sebastian Andrzej Siewior)
>> - massaged the commit messages a bit
>> - drops the powerpc support for PREEMPT_LAZY as that was orthogonal
>> to this series (Shrikanth will send that out separately.)
>>
>> Please review.
>>
>> Ankur Arora (7):
>> rcu: fix header guard for rcu_all_qs()
>> rcu: rename PREEMPT_AUTO to PREEMPT_LAZY
>> sched: update __cond_resched comment about RCU quiescent states
>> rcu: handle unstable rdp in rcu_read_unlock_strict()
>> rcu: handle quiescent states for PREEMPT_RCU=n, PREEMPT_COUNT=y
>> osnoise: provide quiescent states
>> rcu: limit PREEMPT_RCU configurations
>>
>> include/linux/rcupdate.h | 2 +-
>> include/linux/rcutree.h | 2 +-
>> include/linux/srcutiny.h | 2 +-
>> kernel/rcu/Kconfig | 4 ++--
>> kernel/rcu/srcutiny.c | 14 +++++++-------
>> kernel/rcu/tree_plugin.h | 22 +++++++++++++++++-----
>> kernel/sched/core.c | 4 +++-
>> kernel/trace/trace_osnoise.c | 32 +++++++++++++++-----------------
>> 8 files changed, 47 insertions(+), 35 deletions(-)
>>
>> --
>> 2.43.5
>>
--
ankur
Powered by blists - more mailing lists