lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250109105308.6c60dd8c@gandalf.local.home>
Date: Thu, 9 Jan 2025 10:53:08 -0500
From: Steven Rostedt <rostedt@...dmis.org>
To: Peter Zijlstra <peterz@...radead.org>
Cc: Sebastian Andrzej Siewior <bigeasy@...utronix.de>,
 linux-kernel@...r.kernel.org, linux-rt-devel@...ts.linux.dev, Ben Segall
 <bsegall@...gle.com>, Catalin Marinas <catalin.marinas@....com>, Dietmar
 Eggemann <dietmar.eggemann@....com>, Ingo Molnar <mingo@...hat.com>, Juri
 Lelli <juri.lelli@...hat.com>, Mel Gorman <mgorman@...e.de>, Thomas
 Gleixner <tglx@...utronix.de>, Valentin Schneider <vschneid@...hat.com>,
 Vincent Guittot <vincent.guittot@...aro.org>, Will Deacon
 <will@...nel.org>, x86@...nel.org
Subject: Re: [RFC PATCH] preempt: Add a generic function to return the
 preemption string.

On Thu, 9 Jan 2025 15:37:01 +0100
Peter Zijlstra <peterz@...radead.org> wrote:

> > I'm sorry, but I can't even tell what the above is doing without my brain
> > hurting. Why make code that was easy to read into a cryptic obfuscation? I
> > can't see this as an optimization as IS_ENABLED() is determined at compile
> > time.  
> 
> Upgrade brain. Also the proposed thing was just plain wrong.

Or use seq_buf to make it a little more readable again:

const char *preempt_model_str(void)
{
	static char buf[128];
	bool brace = IS_ENABLED(CONFIG_PREEMPT_RT) &&
		     (IS_ENABLED(CONFIG_PREEMPT_DYNAMIC) ||
		      IS_ENABLED(CONFIG_PREEMPT_LAZY));

	if (IS_ENABLED(CONFIG_PREEMPT_BUILD)) {
		struct seq_buf s;

		seq_buf_init(&s, buf, 128);
		seq_buf_puts(&s, "PREEMPT");

		if (IS_ENABLED(CONFIG_PREEMPT_RT))
			seq_buf_printf(&s, "%sRT%s", brace ? "_{" : "_",
					brace ? "," : "");

		if (IS_ENABLED(CONFIG_PREEMPT_DYNAMIC)) {
			seq_buf_printf(&s, "(%s)%s",
				preempt_modes[preempt_dynamic_mode],
				brace ? "}" : "");
			return seq_buf_str(&s);
		}

		if (IS_ENABLED(CONFIG_PREEMPT_LAZY)) {
			seq_buf_printf(&s, "LAZY%s",
				brace ? "}" : "");
			return seq_buf_str(&s);
		}

		return seq_buf_str(&s);
	}

	if (IS_ENABLED(CONFIG_VOLUNTARY_BUILD))
		return "VOLUNTARY";

	return "NONE";
}


At least this removes the need for keeping track of off, len and r.

-- Steve

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ