[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c79dd576-0a85-48e2-a7f8-e4b4e005a18b@icloud.com>
Date: Sat, 11 Jan 2025 07:48:48 +0800
From: Zijun Hu <zijun_hu@...oud.com>
To: Rob Herring <robh@...nel.org>
Cc: Saravana Kannan <saravanak@...gle.com>, Maxime Ripard
<mripard@...nel.org>, Robin Murphy <robin.murphy@....com>,
Grant Likely <grant.likely@...retlab.ca>, Marc Zyngier <maz@...nel.org>,
Andreas Herrmann <andreas.herrmann@...xeda.com>,
Marek Szyprowski <m.szyprowski@...sung.com>,
Catalin Marinas <catalin.marinas@....com>, Mike Rapoport <rppt@...nel.org>,
Oreoluwa Babatunde <quic_obabatun@...cinc.com>, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org, Zijun Hu <quic_zijuhu@...cinc.com>
Subject: Re: [PATCH v4 14/14] of: Improve __of_add_property_sysfs()
readability
On 2025/1/11 04:41, Rob Herring wrote:
> On Thu, Jan 09, 2025 at 09:27:05PM +0800, Zijun Hu wrote:
>> From: Zijun Hu <quic_zijuhu@...cinc.com>
>>
>> __of_add_property_sysfs() hard codes string "security-" length as 9, but
>> that is not obvious for readers.
>>
>> Improve its readability by using strlen().
>
> Does the compiler optimize the strlen call away? Maybe, maybe not. If
> not, that's N calls to strlen() where N is the number of properties in
> your DT. That's in the 1000s easily.
>
> Do you really want to go test enough compiler versions we support to
> feel confident this is optimized away. I don't.
>
i understand your concern about performance.
perhaps, such impact about performance may be ignored for linux OS.
what about below solution ?
const char security_prefix[] = "security-";
use 'sizeof(security_prefix) - 1' for the length of string.
> Rob
>
>>
>> Signed-off-by: Zijun Hu <quic_zijuhu@...cinc.com>
>> ---
>> drivers/of/kobj.c | 3 ++-
>> 1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/of/kobj.c b/drivers/of/kobj.c
>> index aa887166f0d21030d620d43c864ca76cde1c6d05..44bfe50c6ea6503e3940578de1dfc7fe0583dfb3 100644
>> --- a/drivers/of/kobj.c
>> +++ b/drivers/of/kobj.c
>> @@ -62,10 +62,11 @@ static const char *safe_name(const struct kobject *kobj, const char *orig_name)
>>
>> int __of_add_property_sysfs(struct device_node *np, struct property *pp)
>> {
>> + const char *security_prefix = "security-";
>> int rc;
>>
>> /* Important: Don't leak passwords */
>> - bool secure = strncmp(pp->name, "security-", 9) == 0;
>> + bool secure = strncmp(pp->name, security_prefix, strlen(security_prefix)) == 0;
>>
>> if (!IS_ENABLED(CONFIG_SYSFS))
>> return 0;
>>
>> --
>> 2.34.1
>>
Powered by blists - more mailing lists