[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <0bcbbc09-e4dd-4e16-ac1a-c9d3f368c145@daynix.com>
Date: Fri, 10 Jan 2025 18:28:46 +0900
From: Akihiko Odaki <akihiko.odaki@...nix.com>
To: Willem de Bruijn <willemdebruijn.kernel@...il.com>,
Jonathan Corbet <corbet@....net>, Jason Wang <jasowang@...hat.com>,
"David S. Miller" <davem@...emloft.net>, Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
"Michael S. Tsirkin" <mst@...hat.com>, Xuan Zhuo
<xuanzhuo@...ux.alibaba.com>, Shuah Khan <shuah@...nel.org>,
linux-doc@...r.kernel.org, linux-kernel@...r.kernel.org,
netdev@...r.kernel.org, kvm@...r.kernel.org,
virtualization@...ts.linux-foundation.org, linux-kselftest@...r.kernel.org,
Yuri Benditovich <yuri.benditovich@...nix.com>,
Andrew Melnychenko <andrew@...nix.com>,
Stephen Hemminger <stephen@...workplumber.org>, gur.stavi@...wei.com
Subject: Re: [PATCH v6 1/6] virtio_net: Add functions for hashing
On 2025/01/09 23:13, Willem de Bruijn wrote:
> Akihiko Odaki wrote:
>> They are useful to implement VIRTIO_NET_F_RSS and
>> VIRTIO_NET_F_HASH_REPORT.
>
> Toeplitz potentially has users beyond virtio. I wonder if we should
> from the start implement this as net/core/rss.c.
Or in lib/toeplitz.c just as like lib/siphash.c. I just chose the
easiest option to implement everything in include/linux/virtio_net.h.
>
>
>> Signed-off-by: Akihiko Odaki <akihiko.odaki@...nix.com>
>> ---
>> include/linux/virtio_net.h | 188 +++++++++++++++++++++++++++++++++++++++++++++
>> 1 file changed, 188 insertions(+)
>>
>> diff --git a/include/linux/virtio_net.h b/include/linux/virtio_net.h
>> index 02a9f4dc594d..3b25ca75710b 100644
>> --- a/include/linux/virtio_net.h
>> +++ b/include/linux/virtio_net.h
>> @@ -9,6 +9,194 @@
>> #include <uapi/linux/tcp.h>
>> #include <uapi/linux/virtio_net.h>
>>
>> +struct virtio_net_hash {
>> + u32 value;
>> + u16 report;
>> +};
>> +
>> +struct virtio_net_toeplitz_state {
>> + u32 hash;
>> + const u32 *key;
>> +};
>> +
>> +#define VIRTIO_NET_SUPPORTED_HASH_TYPES (VIRTIO_NET_RSS_HASH_TYPE_IPv4 | \
>> + VIRTIO_NET_RSS_HASH_TYPE_TCPv4 | \
>> + VIRTIO_NET_RSS_HASH_TYPE_UDPv4 | \
>> + VIRTIO_NET_RSS_HASH_TYPE_IPv6 | \
>> + VIRTIO_NET_RSS_HASH_TYPE_TCPv6 | \
>> + VIRTIO_NET_RSS_HASH_TYPE_UDPv6)
>> +
>> +#define VIRTIO_NET_RSS_MAX_KEY_SIZE 40
>> +
>> +static inline void virtio_net_toeplitz_convert_key(u32 *input, size_t len)
>> +{
>> + while (len >= sizeof(*input)) {
>> + *input = be32_to_cpu((__force __be32)*input);
>> + input++;
>> + len -= sizeof(*input);
>> + }
>> +}
>> +
>> +static inline void virtio_net_toeplitz_calc(struct virtio_net_toeplitz_state *state,
>> + const __be32 *input, size_t len)
>> +{
>> + while (len >= sizeof(*input)) {
>> + for (u32 map = be32_to_cpu(*input); map; map &= (map - 1)) {
>> + u32 i = ffs(map);
>> +
>> + state->hash ^= state->key[0] << (32 - i) |
>> + (u32)((u64)state->key[1] >> i);
>> + }
>> +
>> + state->key++;
>> + input++;
>> + len -= sizeof(*input);
>> + }
>> +}
>
> Have you verified that this algorithm matches a known toeplitz
> implementation. And computes the expected values for the test
> inputs in
>
> https://learn.microsoft.com/en-us/windows-hardware/drivers/network/verifying-the-rss-hash-calculation
Yes.
>
> We have a toeplitz implementation in
> tools/testing/selftests/net/toeplitz.c that can also be used as
> reference.
> >> +
>> +static inline u8 virtio_net_hash_key_length(u32 types)
>> +{
>> + size_t len = 0;
>> +
>> + if (types & VIRTIO_NET_HASH_REPORT_IPv4)
>> + len = max(len,
>> + sizeof(struct flow_dissector_key_ipv4_addrs));
>> +
>> + if (types &
>> + (VIRTIO_NET_HASH_REPORT_TCPv4 | VIRTIO_NET_HASH_REPORT_UDPv4))
>> + len = max(len,
>> + sizeof(struct flow_dissector_key_ipv4_addrs) +
>> + sizeof(struct flow_dissector_key_ports));
>> +
>> + if (types & VIRTIO_NET_HASH_REPORT_IPv6)
>> + len = max(len,
>> + sizeof(struct flow_dissector_key_ipv6_addrs));
>> +
>> + if (types &
>> + (VIRTIO_NET_HASH_REPORT_TCPv6 | VIRTIO_NET_HASH_REPORT_UDPv6))
>> + len = max(len,
>> + sizeof(struct flow_dissector_key_ipv6_addrs) +
>> + sizeof(struct flow_dissector_key_ports));
>> +
>> + return len + 4;
>
> Avoid magic constants. Please use sizeof or something else to signal
> what this 4 derives from.
Powered by blists - more mailing lists