[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250110100832.27551-1-andyshrk@163.com>
Date: Fri, 10 Jan 2025 18:08:15 +0800
From: Andy Yan <andyshrk@....com>
To: heiko@...ech.de
Cc: hjc@...k-chips.com,
krzk+dt@...nel.org,
devicetree@...r.kernel.org,
dri-devel@...ts.freedesktop.org,
linux-arm-kernel@...ts.infradead.org,
linux-kernel@...r.kernel.org,
linux-rockchip@...ts.infradead.org,
derek.foreman@...labora.com,
detlev.casanova@...labora.com,
daniel@...ishbar.org,
robh@...nel.org,
sebastian.reichel@...labora.com,
Andy Yan <andy.yan@...k-chips.com>
Subject: [PATCH v10 00/11] VOP Support for rk3576
From: Andy Yan <andy.yan@...k-chips.com>
Here is the V10
Patches that have already been merged in drm-misc-next are dropped.
PATCH 1~9 are preparations for rk3576 support
PATCH 10~11 are real support for rk376
I test it with a 1080P/4K HDMI output with modetest and weston
output.
If there are some one want to have a try, I have a tree based on
Linux 6.13-rc6 here[0]
[0]https://github.com/andyshrk/linux/tree/rk3576-vop2-upstream-v10
Links to V9:
https://lore.kernel.org/linux-rockchip/20250108115233.17729-1-andyshrk@163.com/T/#t
Changes in v10:
- Move interrupt-names back to top level
- Add constraint of interrupts for all platform
- Add constraint for all grf phandles
- Reorder some properties
Changes in v9:
- Drop 'vop-' prefix of interrupt-names.
- Add blank line between DT properties
- Remove list interrupt-names in top level
- Drop 'vop-' prefix of interrupt-names.
Changes in v8:
- Remove redundant blank line before drm_bus_format_enum_list
- Add a blank line before DRM_ENUM_NAME_FN
- Fix dt_binding_check errors
- ordered by soc name
- Link to the previous version:
https://lore.kernel.org/linux-rockchip/6pn3qjxotdtpzucpul24yro7ppddezwuizneovqvmgdwyv2j7p@ztg4mqyiqmjf/T/#u
Changes in v7:
- Fix rk3588 dp+dsi maxclk verification
Changes in v6:
- Add a blank line after hardware version check code
- More specific explanation about the AXI_BUS_ID register bit of
cluster window.
Changes in v5:
- Add axi id configuration
- Remove the non-existent CBCR scale register.
Changes in v4:
- Typo fix: selet->select
- describe constraint SOC by SOC, as interrupts of rk3576 is very
different from others
- Drop Krzysztof's Reviewed-by, as this version changed a lot.
Changes in v3:
- Add comments for why we should treat rk3566 with special care.
- Add hardware version check
- Add comments for why we should treat rk3566 with special care.
- ordered by soc name
- Add description for newly added interrupt
- Share the alpha setup function with rk3568
- recoder the code block by soc
Changes in v2:
- Add platform specific callback
- Introduce vop hardware version
- Add dt bindings
- Add platform specific callback
Andy Yan (10):
drm/rockchip: vop2: Rename TRANSFORM_OFFSET to TRANSFORM_OFFS
drm/rockchip: vop2: Add platform specific callback
drm/rockchip: vop2: Merge vop2_cluster/esmart_init function
drm/rockchip: vop2: Support for different layer select configuration
between VPs
drm/rockchip: vop2: Introduce vop hardware version
drm/rockchip: vop2: Register the primary plane and overlay plane
separately
drm/rockchip: vop2: Set plane possible crtcs by possible vp mask
drm/rockchip: vop2: Add uv swap for cluster window
dt-bindings: display: vop2: Add rk3576 support
drm/rockchip: vop2: Add support for rk3576
Heiko Stuebner (1):
drm/rockchip: vop2: use devm_regmap_field_alloc for cluster-regs
.../display/rockchip/rockchip-vop2.yaml | 101 +-
drivers/gpu/drm/rockchip/rockchip_drm_vop2.c | 1473 +++-----------
drivers/gpu/drm/rockchip/rockchip_drm_vop2.h | 275 ++-
drivers/gpu/drm/rockchip/rockchip_vop2_reg.c | 1798 ++++++++++++++++-
4 files changed, 2381 insertions(+), 1266 deletions(-)
--
2.34.1
Powered by blists - more mailing lists