[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250112124056.4c933181@jic23-huawei>
Date: Sun, 12 Jan 2025 12:40:56 +0000
From: Jonathan Cameron <jic23@...nel.org>
To: Jonathan Santos <Jonathan.Santos@...log.com>
Cc: <linux-iio@...r.kernel.org>, <devicetree@...r.kernel.org>,
<linux-kernel@...r.kernel.org>, Sergiu Cuciurean
<sergiu.cuciurean@...log.com>, <lars@...afoo.de>,
<Michael.Hennerich@...log.com>, <robh@...nel.org>, <krzk+dt@...nel.org>,
<conor+dt@...nel.org>, <marcelo.schmitt1@...il.com>
Subject: Re: [PATCH v1 09/15] iio: adc: ad7768-1: Move buffer allocation to
a separate function
On Tue, 7 Jan 2025 12:26:05 -0300
Jonathan Santos <Jonathan.Santos@...log.com> wrote:
> From: Sergiu Cuciurean <sergiu.cuciurean@...log.com>
>
> This change moves the buffer allocation in a separate function, making
> space for adding another type of iio buffer if needed.
>
> Signed-off-by: Sergiu Cuciurean <sergiu.cuciurean@...log.com>
> ---
> drivers/iio/adc/ad7768-1.c | 64 ++++++++++++++++++++++----------------
> 1 file changed, 37 insertions(+), 27 deletions(-)
>
> diff --git a/drivers/iio/adc/ad7768-1.c b/drivers/iio/adc/ad7768-1.c
> index cd1b08053105..eaa9a12737ac 100644
> --- a/drivers/iio/adc/ad7768-1.c
> +++ b/drivers/iio/adc/ad7768-1.c
> @@ -163,6 +163,7 @@ struct ad7768_state {
> struct iio_trigger *trig;
> struct gpio_desc *gpio_sync_in;
> struct gpio_desc *gpio_reset;
> + int irq;
> const char *labels[ARRAY_SIZE(ad7768_channels)];
> /*
> * DMA (thus cache coherency maintenance) may require the
> @@ -569,6 +570,40 @@ static int ad7768_set_channel_label(struct iio_dev *indio_dev,
> return 0;
> }
>
> +static int ad7768_triggered_buffer_alloc(struct iio_dev *indio_dev)
> +{
> + struct ad7768_state *st = iio_priv(indio_dev);
> + int ret;
> +
> + st->trig = devm_iio_trigger_alloc(indio_dev->dev.parent, "%s-dev%d",
> + indio_dev->name,
> + iio_device_id(indio_dev));
> + if (!st->trig)
> + return -ENOMEM;
> +
> + st->trig->ops = &ad7768_trigger_ops;
> + iio_trigger_set_drvdata(st->trig, indio_dev);
> + ret = devm_iio_trigger_register(indio_dev->dev.parent, st->trig);
> + if (ret)
> + return ret;
> +
> + indio_dev->trig = iio_trigger_get(st->trig);
> +
> + init_completion(&st->completion);
> +
> + ret = devm_request_irq(indio_dev->dev.parent, st->irq,
> + &ad7768_interrupt,
> + IRQF_TRIGGER_RISING | IRQF_ONESHOT,
> + indio_dev->name, indio_dev);
> + if (ret)
As with the completion, the interrupt is not just for triggered buffer use
either, so probably doesn't belong in this function. Again, not
a bug to do so, but hurts readability a little.
> + return ret;
> +
> + return devm_iio_triggered_buffer_setup(indio_dev->dev.parent, indio_dev,
> + &iio_pollfunc_store_time,
> + &ad7768_trigger_handler,
> + &ad7768_buffer_ops);
> +}
> +
> static int ad7768_probe(struct spi_device *spi)
> {
> struct ad7768_state *st;
> @@ -610,6 +645,7 @@ static int ad7768_probe(struct spi_device *spi)
> return PTR_ERR(st->mclk);
>
> st->mclk_freq = clk_get_rate(st->mclk);
> + st->irq = spi->irq;
>
> mutex_init(&st->lock);
>
> @@ -625,37 +661,11 @@ static int ad7768_probe(struct spi_device *spi)
> return ret;
> }
>
> - st->trig = devm_iio_trigger_alloc(&spi->dev, "%s-dev%d",
> - indio_dev->name,
> - iio_device_id(indio_dev));
> - if (!st->trig)
> - return -ENOMEM;
> -
> - st->trig->ops = &ad7768_trigger_ops;
> - iio_trigger_set_drvdata(st->trig, indio_dev);
> - ret = devm_iio_trigger_register(&spi->dev, st->trig);
> - if (ret)
> - return ret;
> -
> - indio_dev->trig = iio_trigger_get(st->trig);
> -
> - init_completion(&st->completion);
> -
> ret = ad7768_set_channel_label(indio_dev, ARRAY_SIZE(ad7768_channels));
> if (ret)
> return ret;
>
> - ret = devm_request_irq(&spi->dev, spi->irq,
> - &ad7768_interrupt,
> - IRQF_TRIGGER_RISING | IRQF_ONESHOT,
> - indio_dev->name, indio_dev);
> - if (ret)
> - return ret;
> -
> - ret = devm_iio_triggered_buffer_setup(&spi->dev, indio_dev,
> - &iio_pollfunc_store_time,
> - &ad7768_trigger_handler,
> - &ad7768_buffer_ops);
> + ret = ad7768_triggered_buffer_alloc(indio_dev);
> if (ret)
> return ret;
>
Powered by blists - more mailing lists