[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250112153925.0e7ae045@jic23-huawei>
Date: Sun, 12 Jan 2025 15:39:25 +0000
From: Jonathan Cameron <jic23@...nel.org>
To: Robert Budai <robert.budai@...log.com>
Cc: Nuno Sa <nuno.sa@...log.com>, Ramona Gradinariu
<ramona.gradinariu@...log.com>, Antoniu Miclaus
<antoniu.miclaus@...log.com>, Lars-Peter Clausen <lars@...afoo.de>, Michael
Hennerich <Michael.Hennerich@...log.com>, Rob Herring <robh@...nel.org>,
Krzysztof Kozlowski <krzk+dt@...nel.org>, Conor Dooley
<conor+dt@...nel.org>, Jonathan Corbet <corbet@....net>, Alex Lanzano
<lanzano.alex@...il.com>, <linux-iio@...r.kernel.org>,
<devicetree@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<linux-doc@...r.kernel.org>
Subject: Re: [PATCH v4 3/6] iio: imu: adis: Add DIAG_STAT register size
On Fri, 10 Jan 2025 09:42:51 +0200
Robert Budai <robert.budai@...log.com> wrote:
> Some devices may have more than 16 bits of status. This patch allows the
> user to specify the size of the DIAG_STAT register. It defaults to 2 if
> not specified. This is mainly for backward compatibility.
>
> Co-developed-by: Ramona Gradinariu <ramona.gradinariu@...log.com>
> Signed-off-by: Ramona Gradinariu <ramona.gradinariu@...log.com>
> Co-developed-by: Antoniu Miclaus <antoniu.miclaus@...log.com>
> Signed-off-by: Antoniu Miclaus <antoniu.miclaus@...log.com>
> Signed-off-by: Nuno Sá <nuno.sa@...log.com>
> Signed-off-by: Robert Budai <robert.budai@...log.com>
> ---
> drivers/iio/imu/adis.c | 11 ++++++++---
> include/linux/iio/imu/adis.h | 2 ++
> 2 files changed, 10 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/iio/imu/adis.c b/drivers/iio/imu/adis.c
> index 9e4113473dc4..a072307bfb6a 100644
> --- a/drivers/iio/imu/adis.c
> +++ b/drivers/iio/imu/adis.c
> @@ -304,11 +304,15 @@ EXPORT_SYMBOL_NS(__adis_enable_irq, "IIO_ADISLIB");
> */
> int __adis_check_status(struct adis *adis)
> {
> - u16 status;
> + unsigned int status;
> int ret;
> int i;
>
> - ret = __adis_read_reg_16(adis, adis->data->diag_stat_reg, &status);
> + if (adis->data->diag_stat_size)
> + ret = adis->ops->read(adis, adis->data->diag_stat_reg, &status,
> + adis->data->diag_stat_size);
> + else
> + ret = __adis_read_reg_16(adis, adis->data->diag_stat_reg, (u16 *)&status);
> if (ret)
> return ret;
>
> @@ -317,7 +321,8 @@ int __adis_check_status(struct adis *adis)
> if (status == 0)
> return 0;
>
> - for (i = 0; i < 16; ++i) {
> + for (i = 0; i < BITS_PER_BYTE * ((adis->data->diag_stat_size) ?
> + adis->data->diag_stat_size : 2); ++i) {
This is getting hard to read. I think a local variable is appropriate.
> if (status & BIT(i)) {
> dev_err(&adis->spi->dev, "%s.\n",
> adis->data->status_error_msgs[i]);
> diff --git a/include/linux/iio/imu/adis.h b/include/linux/iio/imu/adis.h
> index 52652f51db2e..b888b22f5c8c 100644
> --- a/include/linux/iio/imu/adis.h
> +++ b/include/linux/iio/imu/adis.h
> @@ -44,6 +44,7 @@ struct adis_timeout {
> * @glob_cmd_reg: Register address of the GLOB_CMD register
> * @msc_ctrl_reg: Register address of the MSC_CTRL register
> * @diag_stat_reg: Register address of the DIAG_STAT register
> + * @diag_stat_size: Length (in bytes) of the DIAG_STAT register.
Add something about 0 being treated as meaning 2. Or add this to
all instances of this structure so we don't need that 0 case.
Whilst there are quite a lot instances, they are mostly filled
by a couple of macros so it shouldn't be too bad to update them all.
> * @prod_id_reg: Register address of the PROD_ID register
> * @prod_id: Product ID code that should be expected when reading @prod_id_reg
> * @self_test_mask: Bitmask of supported self-test operations
> @@ -70,6 +71,7 @@ struct adis_data {
> unsigned int glob_cmd_reg;
> unsigned int msc_ctrl_reg;
> unsigned int diag_stat_reg;
> + unsigned int diag_stat_size;
> unsigned int prod_id_reg;
>
> unsigned int prod_id;
Powered by blists - more mailing lists