[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20250113200252.38124-1-sj@kernel.org>
Date: Mon, 13 Jan 2025 12:02:52 -0800
From: SeongJae Park <sj@...nel.org>
To: Joshua Hahn <joshua.hahnjy@...il.com>
Cc: SeongJae Park <sj@...nel.org>,
kernel-team@...a.com,
damon@...ts.linux.dev,
linux-mm@...ck.org,
linux-kernel@...r.kernel.org
Subject: Re: [RFC PATCH 07/18] mm/damon/paddr: report filter-passed bytes back for DAMOS_STAT action
Hi Joshua,
On Mon, 13 Jan 2025 11:49:37 -0800 Joshua Hahn <joshua.hahnjy@...il.com> wrote:
> On Wed, 18 Dec 2024 20:03:16 -0800 SeongJae Park <sj@...nel.org> wrote:
>
> Hello SJ,
> I hope you are doing well! Sorry to add noise to an old mail, but I recently
> saw Usama's patch that improves this function, and it brought my attention
> to this series, so I have been reading it today.
>
> I was unsure if I should send this mail because I had a nit / naive question
> about the patch:
>
> [...snip...]
>
> > +static unsigned long damon_pa_stat(struct damon_region *r, struct damos *s,
> > + unsigned long *sz_filter_passed)
> > +{
> > + unsigned long addr;
> > + LIST_HEAD(folio_list);
> > +
> > + if (!damon_pa_scheme_has_filter(s))
> > + return 0;
> > +
> > + for (addr = r->ar.start; addr < r->ar.end; addr += PAGE_SIZE) {
> > + struct folio *folio = damon_get_folio(PHYS_PFN(addr));
> > +
> > + if (!folio)
> > + continue;
> > +
> > + if (damos_pa_filter_out(s, folio))
> > + goto put_folio;
> > + else
> > + *sz_filter_passed += folio_size(folio);
> > +put_folio:
> > + folio_put(folio);
> > + }
> > + return 0;
>
> Is there a reason that we decide to use a goto statement here?
There was no special reason. I wrote this function by copying
damon_pa_migrate() and removing parts that not necessary. As a result, the
weird 'goto' has remained.
> As far as I
> can tell, this is the only place this goto statement is used, and the else
> case bleeds into it as well. That is, I believe that the following could be
> more readable:
>
> if (!damos_pa_filter_out(s, folio))
> *sz_filter_passed += folio_size(folio);
>
> folio_put(folio);
> }
> return 0;
I agree. This looks much better! If you don't mind, pleae send a patch!
>
> [...snip...]
>
> Again, I am sorry if this is a naive question.
No worry, thank you for this nice and important question! I believe
readability matters and DAMON code needs many helps for that :)
> Thank you for your time,
> I hope you have a great day!
You too!
Thanks,
SJ
[...]
Powered by blists - more mailing lists