[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <2b249bb11b3c08b21929b46f14bee808c9bbefe6.camel@physik.fu-berlin.de>
Date: Tue, 14 Jan 2025 21:29:45 +0100
From: John Paul Adrian Glaubitz <glaubitz@...sik.fu-berlin.de>
To: Thorsten Blum <thorsten.blum@...ux.dev>, "David S. Miller"
<davem@...emloft.net>, Andreas Larsson <andreas@...sler.com>, Randy Dunlap
<rdunlap@...radead.org>, Bjorn Helgaas <bhelgaas@...gle.com>, Sam Ravnborg
<sam@...nborg.org>, Dawei Li <dawei.li@...ngroup.cn>
Cc: sparclinux@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] sparc/irq: Remove unneeded if check in
sun4v_cookie_only_virqs()
Hi Thorsten,
On Tue, 2025-01-14 at 21:25 +0100, Thorsten Blum wrote:
> Remove the unnecessary if check and return the result directly.
>
> Signed-off-by: Thorsten Blum <thorsten.blum@...ux.dev>
> ---
> arch/sparc/kernel/irq_64.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/arch/sparc/kernel/irq_64.c b/arch/sparc/kernel/irq_64.c
> index aff0d24f8c6f..81fb49b089a8 100644
> --- a/arch/sparc/kernel/irq_64.c
> +++ b/arch/sparc/kernel/irq_64.c
> @@ -146,9 +146,7 @@ static int hv_irq_version;
> */
> static bool sun4v_cookie_only_virqs(void)
> {
> - if (hv_irq_version >= 3)
> - return true;
> - return false;
> + return hv_irq_version >= 3;
> }
>
> static void __init irq_init_hv(void)
I'm not sure whether this change is really necessary nor will it improve
the readability of the code. I think the compiler will optimize the code
the same way, for both variants.
Adrian
--
.''`. John Paul Adrian Glaubitz
: :' : Debian Developer
`. `' Physicist
`- GPG: 62FF 8A75 84E0 2956 9546 0006 7426 3B37 F5B5 F913
Powered by blists - more mailing lists