lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <b5d5208e-a75f-4fae-ab6c-3b847596f06e@intel.com>
Date: Mon, 13 Jan 2025 16:04:42 -0800
From: Jacob Keller <jacob.e.keller@...el.com>
To: Nick Child <nnac123@...ux.ibm.com>, <linux-kernel@...r.kernel.org>
CC: <nick.child@....com>, <netdev@...r.kernel.org>
Subject: Re: [PATCH 3/3] ibmvnic: Print data buffers with kernel API's



On 1/13/2025 2:17 PM, Nick Child wrote:
> Previously, data buffers that were to be printed were cast to 8 byte
> integers and printed. This can lead to buffer overflow if the length
> of the buffer is not a multiple of 8.
> 
> Simplify and safeguard printing by using kernel provided functions
> to print these data blobs.
> 
> Signed-off-by: Nick Child <nnac123@...ux.ibm.com>
> ---
>  drivers/net/ethernet/ibm/ibmvnic.c | 23 ++++++++++++++---------
>  1 file changed, 14 insertions(+), 9 deletions(-)
> 
> diff --git a/drivers/net/ethernet/ibm/ibmvnic.c b/drivers/net/ethernet/ibm/ibmvnic.c
> index e95ae0d39948..a8f1feb9a2e7 100644
> --- a/drivers/net/ethernet/ibm/ibmvnic.c
> +++ b/drivers/net/ethernet/ibm/ibmvnic.c
> @@ -5556,9 +5560,10 @@ static int handle_login_rsp(union ibmvnic_crq *login_rsp_crq,
>  	netdev->mtu = adapter->req_mtu - ETH_HLEN;
>  
>  	netdev_dbg(adapter->netdev, "Login Response Buffer:\n");
> -	for (i = 0; i < (adapter->login_rsp_buf_sz - 1) / 8 + 1; i++) {
> -		netdev_dbg(adapter->netdev, "%016lx\n",
> -			   ((unsigned long *)(adapter->login_rsp_buf))[i]);
> +	for_each_line_in_hex_dump(i, 16, hex_str, sizeof(hex_str), 8,
> +				  adapter->login_rsp_buf,
> +				  adapter->login_rsp_buf_sz) {
> +		netdev_dbg(adapter->netdev, "%s\n", hex_str);
>  	}

This is nicer to read and a bit more flexible than print_hex_dump. Neat.
Strictly you don't need the {} here, but i think its more readable given
all the arguments you have to pass to the for_each_macro over multiple
lines.

Reviewed-by: Jacob Keller <jacob.e.keller@...el.com>

>  
>  	/* Sanity checks */


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ