[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20241209114534.000079a6@huawei.com>
Date: Mon, 9 Dec 2024 11:45:34 +0000
From: Jonathan Cameron <Jonathan.Cameron@...wei.com>
To: Mauro Carvalho Chehab <mchehab+huawei@...nel.org>
CC: "Michael S . Tsirkin" <mst@...hat.com>, Shiju Jose
<shiju.jose@...wei.com>, Ani Sinha <anisinha@...hat.com>, Dongjiu Geng
<gengdongjiu1@...il.com>, Igor Mammedov <imammedo@...hat.com>,
<linux-kernel@...r.kernel.org>, <qemu-arm@...gnu.org>,
<qemu-devel@...gnu.org>
Subject: Re: [PATCH v6 09/16] acpi/ghes: make the GHES record generation
more generic
On Sat, 7 Dec 2024 09:54:15 +0100
Mauro Carvalho Chehab <mchehab+huawei@...nel.org> wrote:
> Split the code into separate functions to allow using the
> common CPER filling code by different error sources.
>
> The generic code was moved to ghes_record_cper_errors(),
> and ghes_gen_err_data_uncorrectable_recoverable() now contains
> only a logic to fill the Generic Error Data part of the record,
> as described at:
>
> ACPI 6.2: 18.3.2.7.1 Generic Error Data
>
> The remaining code to generate a memory error now belongs to
> acpi_ghes_record_errors() function.
>
> A further patch will give it a better name.
>
> Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@...nel.org>
Igor tagged this in previous posting. Any reason for dropping?
>
> # Conflicts:
> # roms/edk2
Should clear this out.
A few formatting things inline but beyond that looks good to me.
Reviewed-by: Jonathan Cameron <Jonathan.Cameron@...wei.com>
> /*
> @@ -383,15 +356,18 @@ void acpi_ghes_add_fw_cfg(AcpiGhesState *ags, FWCfgState *s,
> ags->present = true;
> }
>
> -int acpi_ghes_record_errors(uint16_t source_id, uint64_t physical_address)
> +void ghes_record_cper_errors(const void *cper, size_t len,
> + uint16_t source_id, Error **errp)
> {
> uint64_t error_block_addr, read_ack_register_addr, read_ack_register = 0;
> uint64_t start_addr;
> - bool ret = -1;
> AcpiGedState *acpi_ged_state;
> AcpiGhesState *ags;
>
> - assert(source_id < ACPI_GHES_ERROR_SOURCE_COUNT);
> + if (len > ACPI_GHES_MAX_RAW_DATA_LENGTH) {
> + error_setg(errp, "GHES CPER record is too big: %ld", len);
> + return;
> + }
>
> acpi_ged_state = ACPI_GED(object_resolve_path_type("", TYPE_ACPI_GED,
> NULL));
> @@ -406,6 +382,10 @@ int acpi_ghes_record_errors(uint16_t source_id, uint64_t physical_address)
> sizeof(error_block_addr));
>
> error_block_addr = le64_to_cpu(error_block_addr);
> + if (!error_block_addr) {
> + error_setg(errp, "can not find Generic Error Status Block");
> + return;
> + }
>
> read_ack_register_addr = start_addr +
> ACPI_GHES_ERROR_SOURCE_COUNT * sizeof(uint64_t);
> @@ -415,24 +395,63 @@ int acpi_ghes_record_errors(uint16_t source_id, uint64_t physical_address)
>
> /* zero means OSPM does not acknowledge the error */
> if (!read_ack_register) {
> - error_report("OSPM does not acknowledge previous error,"
> - " so can not record CPER for current error anymore");
> - } else if (error_block_addr) {
> - read_ack_register = cpu_to_le64(0);
> - /*
> - * Clear the Read Ack Register, OSPM will write it to 1 when
> - * it acknowledges this error.
> - */
> - cpu_physical_memory_write(read_ack_register_addr,
> - &read_ack_register, sizeof(uint64_t));
> -
> - ret = acpi_ghes_record_mem_error(error_block_addr,
> - physical_address);
> - } else {
> - error_report("can not find Generic Error Status Block");
> + error_setg(errp,
> + "OSPM does not acknowledge previous error,"
> + " so can not record CPER for current error anymore");
> + return;
> }
>
> - return ret;
> + read_ack_register = cpu_to_le64(0);
> + /*
> + * Clear the Read Ack Register, OSPM will write 1 to this register when
> + * it acknowledges the error.
> + */
> + cpu_physical_memory_write(read_ack_register_addr,
> + &read_ack_register, sizeof(uint64_t));
Maybe rewrap that line now it's indented less?
> +
> + /* Write the generic error data entry into guest memory */
> + cpu_physical_memory_write(error_block_addr, cper, len);
> +
> + return;
> +}
> +
> +int acpi_ghes_record_errors(uint16_t source_id, uint64_t physical_address)
> +{
> + /* Memory Error Section Type */
> + const uint8_t guid[] =
> + UUID_LE(0xA5BC1114, 0x6F64, 0x4EDE, 0xB8, 0x63, 0x3E, 0x83, \
> + 0xED, 0x7C, 0x83, 0xB1);
> + Error *errp = NULL;
> + int data_length;
> + GArray *block;
> +
> + block = g_array_new(false, true /* clear */, 1);
> +
> + data_length = ACPI_GHES_DATA_LENGTH + ACPI_GHES_MEM_CPER_LENGTH;
> + /*
> + * It should not run out of the preallocated memory if adding a new generic
> + * error data entry
> + */
> + assert((data_length + ACPI_GHES_GESB_SIZE) <=
> + ACPI_GHES_MAX_RAW_DATA_LENGTH);
> +
> + ghes_gen_err_data_uncorrectable_recoverable(block, guid,
> + data_length);
Trivial: That fits on one line under 80 chars.
> +
> + /* Build the memory section CPER for above new generic error data entry */
> + acpi_ghes_build_append_mem_cper(block, physical_address);
> +
> + /* Report the error */
> + ghes_record_cper_errors(block->data, block->len, source_id, &errp);
> +
> + g_array_free(block, true);
> +
> + if (errp) {
> + error_report_err(errp);
> + return -1;
> + }
> +
> + return 0;
> }
Powered by blists - more mailing lists