[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAJZ5v0gH+oFmz5+xbW+X1dSXjgt0z-+2b9X-4Oq6FR1EZunvdA@mail.gmail.com>
Date: Tue, 14 Jan 2025 15:37:47 +0100
From: "Rafael J. Wysocki" <rafael@...nel.org>
To: Sudeep Holla <sudeep.holla@....com>, Frederic Weisbecker <frederic@...nel.org>
Cc: LKML <linux-kernel@...r.kernel.org>, Peter Zijlstra <peterz@...radead.org>,
Daniel Lezcano <daniel.lezcano@...aro.org>, linux-pm@...r.kernel.org,
Thomas Gleixner <tglx@...utronix.de>, Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
Dave Hansen <dave.hansen@...ux.intel.com>
Subject: Re: [PATCH 2/6] cpuidle: Introduce CPUIDLE_FLAG_MWAIT
On Tue, Jan 14, 2025 at 3:34 PM Sudeep Holla <sudeep.holla@....com> wrote:
>
> On Tue, Jan 14, 2025 at 03:01:26PM +0100, Rafael J. Wysocki wrote:
> > On Thu, Jan 2, 2025 at 4:02 PM Frederic Weisbecker <frederic@...nel.org> wrote:
> > >
> > > From: Peter Zijlstra <peterz@...radead.org>
> > >
> > > Provide a way to tell the cpuidle core about states monitoring
> > > TIF_NEED_RESCHED on the hardware level, monitor/mwait users being the
> > > only examples in use.
> > >
> > > This will allow cpuidle core to manage TIF_NR_POLLING on behalf of all
> > > kinds of TIF_NEED_RESCHED watching states while keeping a necessary
> > > distinction for the governors between software loops polling on
> > > TIF_NEED_RESCHED and hardware monitored writes to thread flags.
> > >
> > > [fweisbec: _ Initialize flag from acpi_processor_setup_cstates() instead
> > > of acpi_processor_setup_lpi_states(), as the latter seem to
> > > be about arm64...
> > > _ Rename CPUIDLE_FLAG_NO_IPI to CPUIDLE_FLAG_MWAIT]
> > >
> > > Signed-off-by: Peter Zijlstra <peterz@...radead.org>
> > > Signed-off-by: Frederic Weisbecker <frederic@...nel.org>
> > > ---
> > > drivers/acpi/processor_idle.c | 3 +++
> > > drivers/idle/intel_idle.c | 5 ++++-
> > > include/linux/cpuidle.h | 1 +
> > > 3 files changed, 8 insertions(+), 1 deletion(-)
> > >
> > > diff --git a/drivers/acpi/processor_idle.c b/drivers/acpi/processor_idle.c
> > > index 698897b29de2..66cb5536d91e 100644
> > > --- a/drivers/acpi/processor_idle.c
> > > +++ b/drivers/acpi/processor_idle.c
> > > @@ -806,6 +806,9 @@ static int acpi_processor_setup_cstates(struct acpi_processor *pr)
> > > if (cx->type == ACPI_STATE_C1 || cx->type == ACPI_STATE_C2)
> > > drv->safe_state_index = count;
> > >
> > > + if (cx->entry_method == ACPI_CSTATE_FFH)
> > > + state->flags |= CPUIDLE_FLAG_MWAIT;
> >
> > FFH need not mean MWAIT in principle.
> >
> > FFH in _CST means MWAIT in practice because _CST is used on x86 which
> > implements FFH through MWAIT, but it would be good at least to put a
> > comment here to explain that this code is only expected to run on x86.
> >
> > Or better still, add something like acpi_arch_idle_state_flags(u8
> > entry_method) that will return CPUIDLE_FLAG_MWAIT for ACPI_CSTATE_FFH
> > and 0 otherwise and then do
> >
> > state->flags |= acpi_arch_idle_state_flags(cx->entry_method);
> >
>
> +1, was about to suggest the same. Though I am not aware of any Arm platforms
> using C-States(LPI was added to suit Arm requirements), it is better to keep
> the FFH definition arch specific.
Which will be consistent with this patch among other things:
https://lore.kernel.org/linux-pm/20250110115953.6058-3-patryk.wlazlyn@linux.intel.com/
Powered by blists - more mailing lists