[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <Z4h3XHrzB53IAvys@google.com>
Date: Thu, 16 Jan 2025 03:05:00 +0000
From: Pranjal Shrivastava <praan@...gle.com>
To: Krzysztof Kozlowski <krzysztof.kozlowski@...aro.org>
Cc: Will Deacon <will@...nel.org>, Robin Murphy <robin.murphy@....com>,
Joerg Roedel <joro@...tes.org>, Yong Wu <yong.wu@...iatek.com>,
Matthias Brugger <matthias.bgg@...il.com>,
AngeloGioacchino Del Regno <angelogioacchino.delregno@...labora.com>,
Heiko Stuebner <heiko@...ech.de>,
linux-arm-kernel@...ts.infradead.org, iommu@...ts.linux.dev,
linux-kernel@...r.kernel.org, linux-mediatek@...ts.infradead.org,
linux-rockchip@...ts.infradead.org
Subject: Re: [PATCH] iommu: Use str_enable_disable-like helpers
On Tue, Jan 14, 2025 at 08:26:42PM +0100, Krzysztof Kozlowski wrote:
> Replace ternary (condition ? "enable" : "disable") syntax with helpers
> from string_choices.h because:
> 1. Simple function call with one argument is easier to read. Ternary
> operator has three arguments and with wrapping might lead to quite
> long code.
> 2. Is slightly shorter thus also easier to read.
> 3. It brings uniformity in the text - same string.
> 4. Allows deduping by the linker, which results in a smaller binary
> file.
>
> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@...aro.org>
> ---
> drivers/iommu/arm/arm-smmu-v3/arm-smmu-v3.c | 3 ++-
> drivers/iommu/arm/arm-smmu/arm-smmu.c | 3 ++-
> drivers/iommu/mtk_iommu.c | 9 +++++----
> drivers/iommu/mtk_iommu_v1.c | 3 ++-
> drivers/iommu/rockchip-iommu.c | 3 ++-
> 5 files changed, 13 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/iommu/arm/arm-smmu-v3/arm-smmu-v3.c b/drivers/iommu/arm/arm-smmu-v3/arm-smmu-v3.c
> index 0e4cbb2c64d7..358072b4e293 100644
> --- a/drivers/iommu/arm/arm-smmu-v3/arm-smmu-v3.c
> +++ b/drivers/iommu/arm/arm-smmu-v3/arm-smmu-v3.c
> @@ -26,6 +26,7 @@
> #include <linux/pci.h>
> #include <linux/pci-ats.h>
> #include <linux/platform_device.h>
> +#include <linux/string_choices.h>
JFYI, this include was merged in the arm/smmu/updates branch recently,
hence it shouldn't cause any trouble while merging.
> #include <kunit/visibility.h>
> #include <uapi/linux/iommufd.h>
>
> @@ -4321,7 +4322,7 @@ static int arm_smmu_device_hw_probe(struct arm_smmu_device *smmu)
> */
> if (!!(reg & IDR0_COHACC) != coherent)
> dev_warn(smmu->dev, "IDR0.COHACC overridden by FW configuration (%s)\n",
> - coherent ? "true" : "false");
> + str_true_false(coherent));
>
> switch (FIELD_GET(IDR0_STALL_MODEL, reg)) {
> case IDR0_STALL_MODEL_FORCE:
> diff --git a/drivers/iommu/arm/arm-smmu/arm-smmu.c b/drivers/iommu/arm/arm-smmu/arm-smmu.c
> index 79afc92e1d8b..de205a34ffc6 100644
> --- a/drivers/iommu/arm/arm-smmu/arm-smmu.c
> +++ b/drivers/iommu/arm/arm-smmu/arm-smmu.c
> @@ -34,6 +34,7 @@
> #include <linux/pm_runtime.h>
> #include <linux/ratelimit.h>
> #include <linux/slab.h>
> +#include <linux/string_choices.h>
>
> #include <linux/fsl/mc.h>
>
> @@ -2106,7 +2107,7 @@ static void arm_smmu_rmr_install_bypass_smr(struct arm_smmu_device *smmu)
> }
>
> dev_notice(smmu->dev, "\tpreserved %d boot mapping%s\n", cnt,
> - cnt == 1 ? "" : "s");
> + str_plural(cnt));
> iort_put_rmr_sids(dev_fwnode(smmu->dev), &rmr_list);
> }
>
For the arm-smmu part.
Acked-by: Pranjal Shrivastava <praan@...gle.com>
Thanks,
Praan
Powered by blists - more mailing lists