lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAJZ5v0i66dR+grMVZpVM9a1kB5kVHcdiVdDk-9KPxRy2PmTv+w@mail.gmail.com>
Date: Mon, 20 Jan 2025 22:05:56 +0100
From: "Rafael J. Wysocki" <rafael@...nel.org>
To: Linus Torvalds <torvalds@...ux-foundation.org>
Cc: ACPI Devel Maling List <linux-acpi@...r.kernel.org>, Linux PM <linux-pm@...r.kernel.org>, 
	Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: [GIT PULL] ACPI updates for v6.14-rc1

Hi Linus,

Please pull from the tag

 git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git \
 acpi-6.14-rc1

with top-most commit d1ddf94665c6805a63659ab0b09ef626ecc2b0b2

 Merge branches 'acpi-battery', 'acpi-fan' and 'acpi-misc'

on top of commit 14578923e8c251091d2bb8a2756cde3b662ac316

 ACPI: video: Fix random crashes due to bad kfree()

to receive ACPI updates for 6.14-rc1.

The most significant change here is replacing msleep() in acpi_os_sleep()
with usleep_range() to reduce spurious sleep time due to timer inaccuracy
which may spectacularly reduce the duration of system suspend and resume
transitions on some systems.

All of the other changes fall into the fixes and cleanups category this
time.

Specifics:

 - Use usleep_range() instead of msleep() in acpi_os_sleep() to reduce
   excessive delays due to timer inaccuracy, mostly affecting system
   suspend and resume (Rafael Wysocki).

 - Use str_enabled_disabled() string helpers in the ACPI tables parsing
   code to make it easier to follow (Sunil V L).

 - Update device properties parsing on systems using ACPI so that
   data firmware nodes resulting from _DSD evaluation are treated
   as available in firmware nodes walks (Sakari Ailus).

 - Fix missing guid_t declaration in linux/prmt.h (Robert Richter).

 - Update the GHES handling code to follow the global panic= policy
   instead of overriding it by force-rebooting the system after a
   fatal HW error has been reported (Borislav Petkov).

 - Update messages printed by the ACPI battery driver to always
   refer to driver extensions as "hooks" to avoid confusion with
   similar functionality in the power supply subsystem in the
   future (Thomas Weißschuh).

 - Fix .probe() error path cleanup in the ACPI fan driver to avoid
   memory leaks (Joe Hattori).

 - Constify 'struct bin_attribute' in some places in the ACPI subsystem
   and mark it as __ro_after_init in one place to prevent binary blob
   attributes from being updated (Thomas Weißschuh)

 - Add empty stubs for several ACPI-related symbols so that they can be
   used when CONFIG_ACPI is unset and use them for removing unnecessary
   conditional compilation from the ipu-bridge driver (Ricardo Ribalda).

Thanks!


---------------

Borislav Petkov (1):
      APEI: GHES: Have GHES honor the panic= setting

Joe Hattori (1):
      ACPI: fan: cleanup resources in the error path of .probe()

Rafael J. Wysocki (1):
      ACPI: OSL: Use usleep_range() in acpi_os_sleep()

Ricardo Ribalda (7):
      ACPI: bus: change the prototype for acpi_get_physical_device_location
      ACPI: bus: implement for_each_acpi_dev_match when !ACPI
      ACPI: bus: implement acpi_get_physical_device_location when !ACPI
      ACPI: header: implement acpi_device_handle when !ACPI
      ACPI: bus: implement for_each_acpi_consumer_dev when !ACPI
      ACPI: bus: implement acpi_device_hid when !ACPI
      media: ipu-bridge: Remove unneeded conditional compilations

Robert Richter (1):
      ACPI: PRM: Fix missing guid_t declaration in linux/prmt.h

Sakari Ailus (1):
      ACPI: property: Consider data nodes as being available

Sunil V L (1):
      ACPI: tables: Use string choice helpers

Thomas Weißschuh (4):
      ACPI: BGRT: Mark bin_attribute as __ro_after_init
      ACPI: BGRT: Constify 'struct bin_attribute'
      ACPI: sysfs: Constify 'struct bin_attribute'
      ACPI: battery: Rename extensions to hook in messages

---------------

 drivers/acpi/apei/ghes.c             | 10 +++++-----
 drivers/acpi/battery.c               | 14 +++++++-------
 drivers/acpi/bgrt.c                  |  6 +++---
 drivers/acpi/fan_core.c              | 10 ++++++++--
 drivers/acpi/mipi-disco-img.c        |  3 +--
 drivers/acpi/osl.c                   | 22 +++++++++++++++++++++-
 drivers/acpi/property.c              |  2 +-
 drivers/acpi/scan.c                  |  4 +---
 drivers/acpi/sysfs.c                 |  8 ++++----
 drivers/acpi/tables.c                | 12 ++++++------
 drivers/acpi/utils.c                 |  7 +++----
 drivers/base/physical_location.c     |  4 +---
 drivers/media/pci/intel/ipu-bridge.c | 29 ++++-------------------------
 drivers/usb/core/usb-acpi.c          |  3 +--
 include/acpi/acpi_bus.h              | 23 ++++++++++++++++++++---
 include/linux/acpi.h                 |  5 +++++
 include/linux/prmt.h                 |  2 ++
 17 files changed, 93 insertions(+), 71 deletions(-)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ