[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <Z5AaJFUUpzp4VgOo@google.com>
Date: Tue, 21 Jan 2025 14:05:24 -0800
From: Dmitry Torokhov <dmitry.torokhov@...il.com>
To: Linus Torvalds <torvalds@...ux-foundation.org>
Cc: linux-kernel@...r.kernel.org, linux-input@...r.kernel.org
Subject: [git pull] Input updates for v6.14-rc0
Hi Linus,
Please pull from:
git://git.kernel.org/pub/scm/linux/kernel/git/dtor/input.git tags/input-for-v6.14-rc0
to receive updates for the input subsystem. You will get:
- more conversions to the guard notation in the input core
- a fix for NXP BBNSM power key driver to clean up wake IRQ after
unbinding
- several new vendor/device ID pairs added to xpad game controller
driver
- several drivers switched to using str_enable_disable and similar
helpers instead of open-coding
- add mapping for F23 to atkbd driver so that MS "Copilot" key shortcut
works out of the box (if userspace is ready to handle it)
- evbug input handler has been removed (debugging through evdev is
strongly preferred to dumping all events into the kernel log).
Changelog:
---------
Bartosz Golaszewski (1):
Input: davinci-keyscan - remove leftover header
Dmitry Torokhov (9):
Input: ff-core - convert locking to guard notation
Input: ff-core - make use of __free() cleanup facility
Input: ff-memless - convert locking to guard notation
Input: ff-memless - make use of __free() cleanup facility
Input: mt - convert locking to guard notation
Input: mt - make use of __free() cleanup facility
Input: poller - convert locking to guard notation
Input: use guard notation in input core
Input: synaptics - fix crash when enabling pass-through port
Jack Greiner (1):
Input: xpad - add support for wooting two he (arm)
Jiri Kosina (1):
Input: remove evbug driver
Krzysztof Kozlowski (1):
Input: Use str_enable_disable-like helpers
Leonardo Brondani Schenkel (1):
Input: xpad - improve name of 8BitDo controller 2dc8:3106
Luwei Zhou (1):
Input: mma8450 - add chip ID check in probe
Mark Pearson (1):
Input: atkbd - map F23 key to support default copilot shortcut
Matheos Mattsson (1):
Input: xpad - add support for Nacon Evol-X Xbox One Controller
Nicolas Nobelis (1):
Input: xpad - add support for Nacon Pro Compact
Nilton Perim Neto (1):
Input: xpad - add unofficial Xbox 360 wireless receiver clone
Peng Fan (1):
Input: bbnsm_pwrkey - add remove hook
Pierre-Loup A. Griffais (1):
Input: xpad - add QH Electronics VID/PID
Thorsten Blum (1):
Input: joystick - use str_off_on() helper in sw_connect()
Diffstat:
--------
drivers/input/Kconfig | 14 -
drivers/input/Makefile | 1 -
drivers/input/evbug.c | 100 -------
drivers/input/ff-core.c | 91 +++----
drivers/input/ff-memless.c | 18 +-
drivers/input/input-mt.c | 34 +--
drivers/input/input-poller.c | 4 +-
drivers/input/input.c | 339 +++++++++---------------
drivers/input/joystick/sidewinder.c | 3 +-
drivers/input/joystick/xpad.c | 9 +-
drivers/input/keyboard/atkbd.c | 2 +-
drivers/input/keyboard/dlink-dir685-touchkeys.c | 3 +-
drivers/input/keyboard/lm8323.c | 3 +-
drivers/input/misc/max77693-haptic.c | 3 +-
drivers/input/misc/mma8450.c | 16 +-
drivers/input/misc/nxp-bbnsm-pwrkey.c | 8 +
drivers/input/misc/regulator-haptic.c | 3 +-
drivers/input/mouse/elan_i2c_core.c | 3 +-
drivers/input/mouse/synaptics.c | 56 +++-
drivers/input/mouse/synaptics.h | 1 +
drivers/input/touchscreen/egalax_ts.c | 3 +-
include/linux/platform_data/keyscan-davinci.h | 29 --
22 files changed, 275 insertions(+), 468 deletions(-)
delete mode 100644 drivers/input/evbug.c
delete mode 100644 include/linux/platform_data/keyscan-davinci.h
Thanks.
--
Dmitry
Powered by blists - more mailing lists