[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <6e7d7f4b-7a0c-436a-b6a2-5e364411ec87@amd.com>
Date: Fri, 24 Jan 2025 15:26:57 +0530
From: "Nikunj A. Dadhania" <nikunj@....com>
To: "Pratik R. Sampat" <prsampat@....com>, linux-kernel@...r.kernel.org,
x86@...nel.org, kvm@...r.kernel.org, linux-crypto@...r.kernel.org,
linux-kselftest@...r.kernel.org
Cc: seanjc@...gle.com, pbonzini@...hat.com, thomas.lendacky@....com,
tglx@...utronix.de, mingo@...hat.com, bp@...en8.de,
dave.hansen@...ux.intel.com, shuah@...nel.org, pgonda@...gle.com,
ashish.kalra@....com, michael.roth@....com, sraithal@....com
Subject: Re: [PATCH v5 2/9] KVM: SEV: Disable SEV on platform init failure
On 1/24/2025 3:30 AM, Pratik R. Sampat wrote:
> diff --git a/include/linux/psp-sev.h b/include/linux/psp-sev.h
> index e841a8fbbb15..3a40b79fb37f 100644
> --- a/include/linux/psp-sev.h
> +++ b/include/linux/psp-sev.h
> @@ -946,6 +946,7 @@ void *psp_copy_user_blob(u64 uaddr, u32 len);
> void *snp_alloc_firmware_page(gfp_t mask);
> void snp_free_firmware_page(void *addr);
> bool snp_fw_valid(void);
> +bool is_sev_platform_init(void);
>
> #else /* !CONFIG_CRYPTO_DEV_SP_PSP */
>
> @@ -982,6 +983,8 @@ static inline void snp_free_firmware_page(void *addr) { }
>
> static inline bool snp_fw_valid(void) { return false; }
>
> +static inline bool is_sev_platform_init(void) { return false; }
> +
The naming does not sound right, sev_platform_init() does the SEV firmware platform
INIT, so how about calling it sev_fw_initialized()?
Regards,
Nikunj
Powered by blists - more mailing lists