lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <Z6JpOOP1-GpFw7lR@google.com>
Date: Tue, 4 Feb 2025 11:23:36 -0800
From: Sean Christopherson <seanjc@...gle.com>
To: paul@....org
Cc: Paolo Bonzini <pbonzini@...hat.com>, David Woodhouse <dwmw2@...radead.org>, kvm@...r.kernel.org, 
	linux-kernel@...r.kernel.org, 
	syzbot+352e553a86e0d75f5120@...kaller.appspotmail.com, 
	Paul Durrant <pdurrant@...zon.com>, David Woodhouse <dwmw@...zon.co.uk>, 
	Vitaly Kuznetsov <vkuznets@...hat.com>
Subject: Re: [PATCH v2 08/11] KVM: x86: Pass reference pvclock as a param to kvm_setup_guest_pvclock()

On Tue, Feb 04, 2025, Paul Durrant wrote:
> On 04/02/2025 09:33, Paul Durrant wrote:
> > On 01/02/2025 01:38, Sean Christopherson wrote:
> > > -static void kvm_setup_guest_pvclock(struct kvm_vcpu *v,
> > > +static void kvm_setup_guest_pvclock(struct pvclock_vcpu_time_info
> > > *ref_hv_clock,
> > > +                    struct kvm_vcpu *vcpu,
> > 
> > So, here 'v' becomes 'vcpu'
> > 
> > >                       struct gfn_to_pfn_cache *gpc,
> > >                       unsigned int offset,
> > >                       bool force_tsc_unstable)
> > >   {
> > > -    struct kvm_vcpu_arch *vcpu = &v->arch;
> > >       struct pvclock_vcpu_time_info *guest_hv_clock;
> > >       struct pvclock_vcpu_time_info hv_clock;
> > >       unsigned long flags;
> > > -    memcpy(&hv_clock, &vcpu->hv_clock, sizeof(hv_clock));
> > > +    memcpy(&hv_clock, ref_hv_clock, sizeof(hv_clock));
> > >       read_lock_irqsave(&gpc->lock, flags);
> > >       while (!kvm_gpc_check(gpc, offset + sizeof(*guest_hv_clock))) {

...

> > > @@ -3272,18 +3272,18 @@ static int kvm_guest_time_update(struct
> > > kvm_vcpu *v)
> > >               vcpu->hv_clock.flags |= PVCLOCK_GUEST_STOPPED;
> > >               vcpu->pvclock_set_guest_stopped_request = false;
> > >           }
> > > -        kvm_setup_guest_pvclock(v, &vcpu->pv_time, 0, false);
> > > +        kvm_setup_guest_pvclock(&vcpu->hv_clock, v, &vcpu->pv_time,
> > > 0, false);
> > 
> > Yet here an below you still use 'v'. Does this actually compile?
> > 
> 
> Sorry, my misreading of the patch... this is in caller context so no
> problem. The inconsistent naming was misleading me.

I feel your pain, the use of "vcpu" for kvm_vcpu_arch in kvm_guest_time_update()
kills me.  I forget if David's rework of kvm_guest_time_update() fixes that wart.
If it doesn't, I'll suggest that addition.  The only reason I haven't posted a
patch was to avoid a bunch of churn for a rename, but if the function is getting
ripped apart anyways...

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ