[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1c2a1bd6-9ce9-47d8-b89d-1a647575ce07@daynix.com>
Date: Thu, 6 Feb 2025 15:58:34 +0900
From: Akihiko Odaki <akihiko.odaki@...nix.com>
To: Willem de Bruijn <willemdebruijn.kernel@...il.com>,
Jonathan Corbet <corbet@....net>, Jason Wang <jasowang@...hat.com>,
"David S. Miller" <davem@...emloft.net>, Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
"Michael S. Tsirkin" <mst@...hat.com>, Xuan Zhuo
<xuanzhuo@...ux.alibaba.com>, Shuah Khan <shuah@...nel.org>,
linux-doc@...r.kernel.org, linux-kernel@...r.kernel.org,
netdev@...r.kernel.org, kvm@...r.kernel.org,
virtualization@...ts.linux-foundation.org, linux-kselftest@...r.kernel.org,
Yuri Benditovich <yuri.benditovich@...nix.com>,
Andrew Melnychenko <andrew@...nix.com>,
Stephen Hemminger <stephen@...workplumber.org>, gur.stavi@...wei.com,
devel@...nix.com
Subject: Re: [PATCH net-next v5 5/7] tun: Extract the vnet handling code
On 2025/02/06 6:12, Willem de Bruijn wrote:
> Akihiko Odaki wrote:
>> The vnet handling code will be reused by tap.
>>
>> Signed-off-by: Akihiko Odaki <akihiko.odaki@...nix.com>
>> ---
>> MAINTAINERS | 2 +-
>> drivers/net/tun.c | 179 +----------------------------------------------
>> drivers/net/tun_vnet.h | 184 +++++++++++++++++++++++++++++++++++++++++++++++++
>> 3 files changed, 187 insertions(+), 178 deletions(-)
>
>> -static inline bool tun_legacy_is_little_endian(unsigned int flags)
>> -{
>> - return !(IS_ENABLED(CONFIG_TUN_VNET_CROSS_LE) &&
>> - (flags & TUN_VNET_BE)) &&
>> - virtio_legacy_is_little_endian();
>> -}
>
>> +static inline bool tun_vnet_legacy_is_little_endian(unsigned int flags)
>> +{
>> + return !(IS_ENABLED(CONFIG_TUN_VNET_CROSS_LE) &&
>> + (flags & TUN_VNET_BE)) &&
>> + virtio_legacy_is_little_endian();
>> +}
>
> In general LGTM. But why did you rename functions while moving them?
> Please add an explanation in the commit message for any non obvious
> changes like that.
I renamed them to clarify they are in a distinct, decoupled part of
code. It was obvious in the previous version as they are static
functions contained in a translation unit, but now they are part of a
header file so I'm clarifying that with this rename. I will add this
explanation to the commit message.
Powered by blists - more mailing lists