[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20250208013539.3586855-1-l1138897701@163.com>
Date: Sat, 8 Feb 2025 09:35:39 +0800
From: l1138897701@....com
To: jani.nikula@...ux.intel.com
Cc: luoqing@...inos.cn,
linux-kernel@...r.kernel.org
Subject: [PATCH] selftests: i915: Use struct_size() helper in kmalloc()
From: luoqing <luoqing@...inos.cn>
Make use of the struct_size() helper instead of an open-coded version,
in order to avoid any potential type mistakes or integer overflows that,
in the worst scenario, could lead to heap overflows.
Signed-off-by: luoqing <luoqing@...inos.cn>
---
drivers/gpu/drm/i915/gem/selftests/mock_dmabuf.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/i915/gem/selftests/mock_dmabuf.c b/drivers/gpu/drm/i915/gem/selftests/mock_dmabuf.c
index 075657018739..5cd58e0f0dcf 100644
--- a/drivers/gpu/drm/i915/gem/selftests/mock_dmabuf.c
+++ b/drivers/gpu/drm/i915/gem/selftests/mock_dmabuf.c
@@ -103,8 +103,7 @@ static struct dma_buf *mock_dmabuf(int npages)
struct dma_buf *dmabuf;
int i;
- mock = kmalloc(sizeof(*mock) + npages * sizeof(struct page *),
- GFP_KERNEL);
+ mock = kmalloc(struct_size(mock, pages, npages), GFP_KERNEL);
if (!mock)
return ERR_PTR(-ENOMEM);
--
2.27.0
Powered by blists - more mailing lists