[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20250211214842.1806521-1-shyamsaini@linux.microsoft.com>
Date: Tue, 11 Feb 2025 13:48:38 -0800
From: Shyam Saini <shyamsaini@...ux.microsoft.com>
To: linux-kernel@...r.kernel.org,
linux-modules@...r.kernel.org
Cc: code@...icks.com,
linux@...musvillemoes.dk,
christophe.leroy@...roup.eu,
hch@...radead.org,
mcgrof@...nel.org,
frkaya@...ux.microsoft.com,
vijayb@...ux.microsoft.com,
petr.pavlu@...e.com,
linux@...ssschuh.net,
samitolvanen@...gle.com,
da.gomez@...sung.com,
gregkh@...uxfoundation.org,
rafael@...nel.org,
dakr@...nel.org
Subject: [PATCH v3 0/4] Properly handle module_kobject creation
Hi Everyone,
This patch series fixes handling of module_kobject creation.
A driver expect module_kset list populated with its corresponding
module_kobject to create its /sys/module/<built-in-module>/drivers
directory.
Since,
[1] commit 96a1a2412acb ("kernel/params.c: defer most of param_sysfs_init() to late_initcall time")
Call to populate module_kset list is deferred to save init time so that
external watchdog doesn't fireup on some boards and Linux can take
responsibility of feeding watchdog before it spuriously resets the
system. However, [1] this fix caused another issue i.e, consumers
of module_kset can't get related module_kobject during driver
initialisation and hence can't create their
/sys/module/<built-in-module>/drivers directory.
Consequently, [1] breaks user-space applications for eg: DPDK, which
expects /sys/module/vfio_pci/drivers/pci:vfio-pci/new_id to be present.
The second issue was reported and the [2] revert of [1] was
proposed. However, [2] the Revert doesn't address the original issue
reported in [1].
This patch series addresses both issues reported in [1] and [2].
[1] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=96a1a2412acb
[2] https://lore.kernel.org/lkml/20250130225803.321004-1-shyamsaini@linux.microsoft.com/
Thanks,
Shyam
---
- Changes in v3:
- Split refactoring and globalisation of lookup_or_create_module_kobject() into two patches
- Fix commit message to better describe the change.
- Use IS_ENABLED instead of #ifdef macro construct
- Undo the moving of __modinit macro construct into module.h
- drop __modinit from lookup_or_create_module_kobject() declaration
Changes in v2:
- Undo the moving of to_module* and lookup_or_create_module_kobject() into module.h
- Refactor and globalize lookup_or_create_module_kobject()
- move __modinit macro construct to module.h
- Fix commit message typos
Changes in v1:
- Rename locate_module_kobject() to lookup_or_create_module_kobject() to accurately
describe its operations.
- Moves lookup_or_create_module_kobject() and to_module* macros to module.h, so
that driver code can use these.
- Handle module_kobject creation and population of module_kset list to fix [1]
and [2] issues.
- Link: https://lore.kernel.org/lkml/20250204052222.1611510-1-shyamsaini@linux.microsoft.com/
Changes in RFC:
Reverts commit 96a1a2412acb ("kernel/params.c: defer most of param_sysfs_init() to late_initcall time")
Shyam Saini (4):
kernel: param: rename locate_module_kobject
kernel: refactor lookup_or_create_module_kobject()
kernel: globalize lookup_or_create_module_kobject()
drivers: base: handle module_kobject creation
drivers/base/module.c | 13 +++++------
include/linux/module.h | 2 ++
kernel/params.c | 49 ++++++++++++++++++++----------------------
3 files changed, 30 insertions(+), 34 deletions(-)
--
2.34.1
Powered by blists - more mailing lists