[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20250212-arm_fix_selftest-v3-0-72596cb77e44@debian.org>
Date: Wed, 12 Feb 2025 09:47:23 -0800
From: Breno Leitao <leitao@...ian.org>
To: "David S. Miller" <davem@...emloft.net>,
Eric Dumazet <edumazet@...gle.com>, Jakub Kicinski <kuba@...nel.org>,
Paolo Abeni <pabeni@...hat.com>, Simon Horman <horms@...nel.org>,
Andrew Lunn <andrew+netdev@...n.ch>, David Ahern <dsahern@...nel.org>
Cc: linux-kernel@...r.kernel.org, netdev@...r.kernel.org,
Breno Leitao <leitao@...ian.org>, kuniyu@...zon.co.jp,
ushankar@...estorage.com, kernel-team@...a.com,
Kuniyuki Iwashima <kuniyu@...zon.com>
Subject: [PATCH net-next v3 0/3] net: core: improvements to device lookup
by hardware address.
The first patch adds missing documentation for the return value of
dev_getbyhwaddr_rcu(), fixing a warning reported by NIPA. The kdoc
comment now properly specifies that the function returns either a
pointer to net_device or NULL when no matching device is found.
The second patch adds a new dev_getbyhwaddr() helper function for
finding devices by hardware address when the RTNL lock is held. This
prevents PROVE_LOCKING warnings that occurred when RTNL was held but the
RCU read lock wasn't. The common address comparison logic is extracted
into dev_comp_addr() to avoid code duplication.
The third part coverts arp_req_set_public() to the new helper.
Signed-off-by: Breno Leitao <leitao@...ian.org>
---
Changes in v3:
- Fixed the cover letter (Kuniyuki Iwashima)
- Added a third patch converting arp_req_set_public() to the new helper
(Kuniyuki Iwashima)
- Link to v2:
https://lore.kernel.org/r/20250210-arm_fix_selftest-v2-0-ba84b5bc58c8@debian.org
Changes in v2:
- Fixed the documentation (Jakub)
- Renamed the function from dev_getbyhwaddr_rtnl() to dev_getbyhwaddr()
(Jakub)
- Exported the function in the header (Jakub)
- Link to v1: https://lore.kernel.org/r/20250207-arm_fix_selftest-v1-1-487518d2fd1c@debian.org
---
Breno Leitao (3):
net: document return value of dev_getbyhwaddr_rcu()
net: Add dev_getbyhwaddr_rtnl() helper
arp: switch to dev_getbyhwaddr() in arp_req_set_public()
include/linux/netdevice.h | 2 ++
net/core/dev.c | 38 ++++++++++++++++++++++++++++++++++----
net/ipv4/arp.c | 2 +-
3 files changed, 37 insertions(+), 5 deletions(-)
---
base-commit: 4e41231249f4083a095085ff86e317e29313c2c3
change-id: 20250207-arm_fix_selftest-ee29dbc33a06
Best regards,
--
Breno Leitao <leitao@...ian.org>
Powered by blists - more mailing lists