[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250213182527.3092371-1-andriy.shevchenko@linux.intel.com>
Date: Thu, 13 Feb 2025 20:23:59 +0200
From: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Bartosz Golaszewski <bartosz.golaszewski@...aro.org>,
Alexandru Ardelean <aardelean@...libre.com>,
dri-devel@...ts.freedesktop.org,
linux-kernel@...r.kernel.org,
linux-gpio@...r.kernel.org
Cc: Maarten Lankhorst <maarten.lankhorst@...ux.intel.com>,
Maxime Ripard <mripard@...nel.org>,
Thomas Zimmermann <tzimmermann@...e.de>,
David Airlie <airlied@...il.com>,
Simona Vetter <simona@...ll.ch>,
Linus Walleij <linus.walleij@...aro.org>,
Bartosz Golaszewski <brgl@...ev.pl>
Subject: [PATCH v2 0/2] gpiolib: Make code more robust by using for_each_if()
Instead of opencoding with long lines, use for_each_if() macro
which makes intention clearer and less error prone.
In v2:
- moved original for_each_if() implementation to the global header (Bart)
Andy Shevchenko (2):
drm: Move for_each_if() to util_macros.h for wider use
gpiolib: Switch to use for_each_if() helper
include/drm/drm_util.h | 16 +---------------
include/linux/gpio/driver.h | 7 ++++---
include/linux/util_macros.h | 15 +++++++++++++++
3 files changed, 20 insertions(+), 18 deletions(-)
--
2.45.1.3035.g276e886db78b
Powered by blists - more mailing lists