[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250214162407.00002efc@huawei.com>
Date: Fri, 14 Feb 2025 16:24:07 +0000
From: Jonathan Cameron <Jonathan.Cameron@...wei.com>
To: Robert Richter <rrichter@....com>
CC: Alison Schofield <alison.schofield@...el.com>, Vishal Verma
<vishal.l.verma@...el.com>, Ira Weiny <ira.weiny@...el.com>, Dan Williams
<dan.j.williams@...el.com>, Dave Jiang <dave.jiang@...el.com>, "Davidlohr
Bueso" <dave@...olabs.net>, <linux-cxl@...r.kernel.org>,
<linux-kernel@...r.kernel.org>, Gregory Price <gourry@...rry.net>, "Fabio M.
De Francesco" <fabio.m.de.francesco@...ux.intel.com>, Terry Bowman
<terry.bowman@....com>
Subject: Re: [PATCH v3 11/18] cxl/region: Split region registration into an
initialization and adding part
On Tue, 11 Feb 2025 10:53:41 +0100
Robert Richter <rrichter@....com> wrote:
> Before adding an endpoint to a region, the endpoint is initialized
> first. Move that part to a new function
> cxl_endpoint_decoder_initialize(). The function is in preparation of
> adding more parameters that need to be determined in a setup.
>
> The split also helps better separating the code. After initialization
> the addition of an endpoint may fail with an error code and all the
> data would need to be reverted to not leave the endpoint in an
> undefined state. With separate functions the init part can succeed
> even if the endpoint cannot be added.
>
> Function naming follows the style of device_register() etc. Thus,
> rename function cxl_add_to_region() to
> cxl_endpoint_decoder_register().
Hi Robert,
Superficially I'd expect a call of that name to be registering
the device for the decoder. i.e. being the thing that makes
/sys/bus/cxl/devices/decoder3.2 appear.
This register naming is based on the other two being initalize
and add, but they aren't initializing and adding the
endpoint decode device. Hence I don't think those names work either.
>
> Signed-off-by: Robert Richter <rrichter@....com>
> Reviewed-by: Gregory Price <gourry@...rry.net>
> Tested-by: Gregory Price <gourry@...rry.net>
> ---
> drivers/cxl/core/region.c | 36 ++++++++++++++++++++++++++++--------
> drivers/cxl/cxl.h | 6 ++++--
> drivers/cxl/port.c | 9 +++++----
> 3 files changed, 37 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/cxl/core/region.c b/drivers/cxl/core/region.c
> index 9ce0282c0042..fb43e154c7b9 100644
> --- a/drivers/cxl/core/region.c
> +++ b/drivers/cxl/core/region.c
> @@ -3345,7 +3345,7 @@ static struct cxl_region *construct_region(struct cxl_root_decoder *cxlrd,
> dev_name(&cxlr->dev), p->res, p->interleave_ways,
> p->interleave_granularity);
>
> - /* ...to match put_device() in cxl_add_to_region() */
> + /* ...to match put_device() in cxl_endpoint_decoder_add() */
> get_device(&cxlr->dev);
> up_write(&cxl_region_rwsem);
>
> @@ -3357,19 +3357,28 @@ static struct cxl_region *construct_region(struct cxl_root_decoder *cxlrd,
> return ERR_PTR(rc);
> }
>
> -int cxl_add_to_region(struct cxl_endpoint_decoder *cxled)
> +static int cxl_endpoint_decoder_initialize(struct cxl_endpoint_decoder *cxled)
So far this looks like it should be called something like
cxl_endpoint_decoder_init_region_decoder()
or something like that. The cxled is already intialized more generally
and the cxled->cxld.dev is registered.
> {
> - struct range *hpa = &cxled->cxld.hpa_range;
> struct cxl_root_decoder *cxlrd;
> - struct cxl_region_params *p;
> - struct cxl_region *cxlr;
> - bool attach = false;
> - int rc;
>
> cxlrd = cxl_find_root_decoder(cxled);
> if (!cxlrd)
> return -ENXIO;
>
> + cxled->cxlrd = cxlrd;
> +
> + return 0;
> +}
> +
> +static int cxl_endpoint_decoder_add(struct cxl_endpoint_decoder *cxled)
It's not adding what I'd expect such a function to add.
Rather it is performing an association with a region.
> +{
> + struct range *hpa = &cxled->cxld.hpa_range;
> + struct cxl_root_decoder *cxlrd = cxled->cxlrd;
> + struct cxl_region_params *p;
> + struct cxl_region *cxlr;
> + bool attach = false;
> + int rc;
> +
> /*
> * Ensure that if multiple threads race to construct_region() for @hpa
> * one does the construction and the others add to that.
> @@ -3406,7 +3415,18 @@ int cxl_add_to_region(struct cxl_endpoint_decoder *cxled)
>
> return rc;
> }
> -EXPORT_SYMBOL_NS_GPL(cxl_add_to_region, "CXL");
> +
> +int cxl_endpoint_decoder_register(struct cxl_endpoint_decoder *cxled)
> +{
> + int rc;
> +
> + rc = cxl_endpoint_decoder_initialize(cxled);
> + if (rc)
> + return rc;
> +
> + return cxl_endpoint_decoder_add(cxled);
> +}
> +EXPORT_SYMBOL_NS_GPL(cxl_endpoint_decoder_register, "CXL");
Powered by blists - more mailing lists