[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <7d9d0ba9-a503-4009-8dd9-ded51c620128@redhat.com>
Date: Sat, 15 Feb 2025 09:48:31 +1000
From: Gavin Shan <gshan@...hat.com>
To: David Hildenbrand <david@...hat.com>, linux-mm@...ck.org
Cc: linux-kernel@...r.kernel.org, osalvador@...e.de,
gregkh@...uxfoundation.org, rafael@...nel.org, dakr@...nel.org,
akpm@...ux-foundation.org
Subject: Re: [PATCH 1/2] drivers/base/memory: Simplify add_boot_memory_block()
On 2/14/25 5:53 PM, David Hildenbrand wrote:
> On 14.02.25 07:35, Gavin Shan wrote:
>> It's unnecessary to keep the variable @section_count in the function
>> because the device for the specific memory block will be added if
>> any of its memory section is present. The variable @section_count
>> records the number of present memory sections in the specific memory
>> block, which isn't needed.
>>
>> Simplify the function by dropping the variable @section_count. No
>> functional change intended.
>>
>> Signed-off-by: Gavin Shan <gshan@...hat.com>
>> ---
>> drivers/base/memory.c | 15 +++++++--------
>> 1 file changed, 7 insertions(+), 8 deletions(-)
>>
>> diff --git a/drivers/base/memory.c b/drivers/base/memory.c
>> index 348c5dbbfa68..208b9b544012 100644
>> --- a/drivers/base/memory.c
>> +++ b/drivers/base/memory.c
>> @@ -822,18 +822,17 @@ static int add_memory_block(unsigned long block_id, unsigned long state,
>> static int __init add_boot_memory_block(unsigned long base_section_nr)
>> {
>> - int section_count = 0;
>> unsigned long nr;
>> for (nr = base_section_nr; nr < base_section_nr + sections_per_block;
>> - nr++)
>> - if (present_section_nr(nr))
>> - section_count++;
>> + nr++) {
>> + if (present_section_nr(nr)) {
>> + return add_memory_block(memory_block_id(base_section_nr),
>> + MEM_ONLINE, NULL, NULL);
>> + }
>
> Superfluous set of braces for the if statement.
>
> Not sure I count this while thing here as a "simplifcation" -- the code is IMHO easier to read without the nested return in the loop body.
>
> No strong opinion, though.
>
Indeed. I will use for_each_present_section_nr() as Andrew suggested. With it,
one level of the nested if statement can be avoided. The point was to avoid
counting the number of present sections in the specified block since the block
will be added if any section is present.
Thanks,
Gavin
Powered by blists - more mailing lists