[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAAOTY_-BaK-160A4=oWKkEuYnJE69BXqk7CY3yoc71zn-M9y+Q@mail.gmail.com>
Date: Wed, 19 Feb 2025 22:06:35 +0800
From: Chun-Kuang Hu <chunkuang.hu@...nel.org>
To: AngeloGioacchino Del Regno <angelogioacchino.delregno@...labora.com>
Cc: chunkuang.hu@...nel.org, p.zabel@...gutronix.de, airlied@...il.com,
simona@...ll.ch, maarten.lankhorst@...ux.intel.com, mripard@...nel.org,
tzimmermann@...e.de, robh@...nel.org, krzk+dt@...nel.org, conor+dt@...nel.org,
matthias.bgg@...il.com, ck.hu@...iatek.com, jitao.shi@...iatek.com,
jie.qiu@...iatek.com, junzhi.zhao@...iatek.com,
dri-devel@...ts.freedesktop.org, linux-mediatek@...ts.infradead.org,
devicetree@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org, kernel@...labora.com,
dmitry.baryshkov@...aro.org, lewis.liao@...iatek.com,
ives.chenjh@...iatek.com, tommyyl.chen@...iatek.com,
jason-jh.lin@...iatek.com
Subject: Re: [PATCH v7 19/43] drm/mediatek: mtk_hdmi: Fix typo for
aud_sampe_size member
Hi, Angelo:
AngeloGioacchino Del Regno <angelogioacchino.delregno@...labora.com> 於
2025年2月17日 週一 下午11:49寫道:
>
> Rename member aud_sampe_size of struct hdmi_audio_param to
> aud_sample_size to fix a typo and enhance readability.
>
> This commit brings no functional changes.
Applied to mediatek-drm-next [1], thanks.
[1] https://git.kernel.org/pub/scm/linux/kernel/git/chunkuang.hu/linux.git/log/?h=mediatek-drm-next
Regards,
Chun-Kuang.
>
> Fixes: 8f83f26891e1 ("drm/mediatek: Add HDMI support")
> Reviewed-by: CK Hu <ck.hu@...iatek.com>
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@...labora.com>
> ---
> drivers/gpu/drm/mediatek/mtk_hdmi.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/gpu/drm/mediatek/mtk_hdmi.c b/drivers/gpu/drm/mediatek/mtk_hdmi.c
> index 29000cfcf761..6257503ce639 100644
> --- a/drivers/gpu/drm/mediatek/mtk_hdmi.c
> +++ b/drivers/gpu/drm/mediatek/mtk_hdmi.c
> @@ -136,7 +136,7 @@ enum hdmi_aud_channel_swap_type {
>
> struct hdmi_audio_param {
> enum hdmi_audio_coding_type aud_codec;
> - enum hdmi_audio_sample_size aud_sampe_size;
> + enum hdmi_audio_sample_size aud_sample_size;
> enum hdmi_aud_input_type aud_input_type;
> enum hdmi_aud_i2s_fmt aud_i2s_fmt;
> enum hdmi_aud_mclk aud_mclk;
> @@ -1033,7 +1033,7 @@ static int mtk_hdmi_output_init(struct mtk_hdmi *hdmi)
>
> hdmi->csp = HDMI_COLORSPACE_RGB;
> aud_param->aud_codec = HDMI_AUDIO_CODING_TYPE_PCM;
> - aud_param->aud_sampe_size = HDMI_AUDIO_SAMPLE_SIZE_16;
> + aud_param->aud_sample_size = HDMI_AUDIO_SAMPLE_SIZE_16;
> aud_param->aud_input_type = HDMI_AUD_INPUT_I2S;
> aud_param->aud_i2s_fmt = HDMI_I2S_MODE_I2S_24BIT;
> aud_param->aud_mclk = HDMI_AUD_MCLK_128FS;
> @@ -1529,14 +1529,14 @@ static int mtk_hdmi_audio_hw_params(struct device *dev, void *data,
> switch (daifmt->fmt) {
> case HDMI_I2S:
> hdmi_params.aud_codec = HDMI_AUDIO_CODING_TYPE_PCM;
> - hdmi_params.aud_sampe_size = HDMI_AUDIO_SAMPLE_SIZE_16;
> + hdmi_params.aud_sample_size = HDMI_AUDIO_SAMPLE_SIZE_16;
> hdmi_params.aud_input_type = HDMI_AUD_INPUT_I2S;
> hdmi_params.aud_i2s_fmt = HDMI_I2S_MODE_I2S_24BIT;
> hdmi_params.aud_mclk = HDMI_AUD_MCLK_128FS;
> break;
> case HDMI_SPDIF:
> hdmi_params.aud_codec = HDMI_AUDIO_CODING_TYPE_PCM;
> - hdmi_params.aud_sampe_size = HDMI_AUDIO_SAMPLE_SIZE_16;
> + hdmi_params.aud_sample_size = HDMI_AUDIO_SAMPLE_SIZE_16;
> hdmi_params.aud_input_type = HDMI_AUD_INPUT_SPDIF;
> break;
> default:
> --
> 2.48.1
>
Powered by blists - more mailing lists