lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <6e03b0c09c4e6d222670025c6540f73a0a0a819d.camel@pengutronix.de>
Date: Thu, 20 Feb 2025 16:45:39 +0100
From: Philipp Zabel <p.zabel@...gutronix.de>
To: Laurentiu Mihalcea <laurentiumihalcea111@...il.com>, Daniel Baluta
	 <daniel.baluta@....com>, robh@...nel.org, shawnguo@...nel.org
Cc: krzk+dt@...nel.org, conor+dt@...nel.org, s.hauer@...gutronix.de, 
	kernel@...gutronix.de, festevam@...il.com, linux-kernel@...r.kernel.org, 
	devicetree@...r.kernel.org, imx@...ts.linux.dev, 
	linux-arm-kernel@...ts.infradead.org, mathieu.poirier@...aro.org, 
	shengjiu.wang@....com, Frank.Li@....com, peng.fan@....com, 
	laurentiu.mihalcea@....com, iuliana.prodan@....com
Subject: Re: [PATCH v2 8/8] imx_dsp_rproc: Use reset controller API to
 control the DSP

On Do, 2025-02-20 at 00:22 +0200, Laurentiu Mihalcea wrote:
> 
> On 2/19/2025 9:21 PM, Daniel Baluta wrote:
> > Use the reset controller API to control the DSP on i.MX8MP. This way
> > we can have a better control of the resources and avoid using a syscon
> > to access the audiomix bits.
> > 
> > Signed-off-by: Daniel Baluta <daniel.baluta@....com>
> > Reviewed-by: Peng Fan <peng.fan@....com>
> > ---
> >  drivers/remoteproc/imx_dsp_rproc.c | 25 +++++++++++++++++--------
> >  drivers/remoteproc/imx_rproc.h     |  2 ++
> >  2 files changed, 19 insertions(+), 8 deletions(-)
> > 
> > diff --git a/drivers/remoteproc/imx_dsp_rproc.c b/drivers/remoteproc/imx_dsp_rproc.c
> > index ea5024919c2f..631563e4f86d 100644
> > --- a/drivers/remoteproc/imx_dsp_rproc.c
> > +++ b/drivers/remoteproc/imx_dsp_rproc.c
> > @@ -19,6 +19,7 @@
> >  #include <linux/pm_runtime.h>
> >  #include <linux/regmap.h>
> >  #include <linux/remoteproc.h>
> > +#include <linux/reset.h>
> >  #include <linux/slab.h>
> >  
> >  #include "imx_rproc.h"
> > @@ -111,6 +112,7 @@ enum imx_dsp_rp_mbox_messages {
> >   */
> >  struct imx_dsp_rproc {
> >  	struct regmap				*regmap;
> > +	struct reset_control			*reset;
> 
> Maybe rename this to "stall"? There's also the DAP stuff that's actually used
> to reset the core so this might be a bit confusing?

So Run/Stall does not actually reset anything? Maybe then it should not
be modeled as a reset control. It looks to me like the
DAP_PWRCTL[CORERESET] bit in the Audio Processor Debug region would be
a much better fit.

regards
Philipp

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ