[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <41cf1c79-f61c-47e7-a0ed-afb8e82d50e6@nvidia.com>
Date: Wed, 19 Feb 2025 16:14:31 -0800
From: John Hubbard <jhubbard@...dia.com>
To: Daniel Almeida <daniel.almeida@...labora.com>, Dave Airlie
<airlied@...il.com>
CC: Alexandre Courbot <acourbot@...dia.com>, Timur Tabi <ttabi@...dia.com>,
"dri-devel@...ts.freedesktop.org" <dri-devel@...ts.freedesktop.org>,
"rust-for-linux@...r.kernel.org" <rust-for-linux@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"nouveau@...ts.freedesktop.org" <nouveau@...ts.freedesktop.org>,
"dakr@...nel.org" <dakr@...nel.org>, Ben Skeggs <bskeggs@...dia.com>
Subject: Re: [PATCH RFC 1/3] rust: add useful ops for u64
On 2/19/25 3:13 PM, Daniel Almeida wrote:
>> On 19 Feb 2025, at 17:23, Dave Airlie <airlied@...il.com> wrote:
>> On Thu, 20 Feb 2025 at 06:22, John Hubbard <jhubbard@...dia.com> wrote:
>>> On 2/19/25 4:51 AM, Alexandre Courbot wrote:
>>>> Yes, that looks like the optimal way to do this actually. It also
>>>> doesn't introduce any overhead as the destructuring was doing both
>>>> high_half() and low_half() in sequence, so in some cases it might
>>>> even be more efficient.
>>>>
>>>> I'd just like to find a better naming. high() and low() might be enough?
>>>> Or are there other suggestions?
>>>>
>>>
>>> Maybe use "32" instead of "half":
>>>
>>> .high_32() / .low_32()
>>> .upper_32() / .lower_32()
>>>
>>
>> The C code currently does upper_32_bits and lower_32_bits, do we want
>> to align or diverge here?
This sounds like a trick question, so I'm going to go with..."align". haha :)
>>
>> Dave.
>
>
> My humble suggestion here is to use the same nomenclature. `upper_32_bits` and
> `lower_32_bits` immediately and succinctly informs the reader of what is going on.
>
Yes. I missed the pre-existing naming in C, but since we have it and it's
well-named as well, definitely this is the way to go.
thanks,
--
John Hubbard
Powered by blists - more mailing lists