lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <d03103b9cab4a1d2d779b3044f340c6d@dev.tdt.de>
Date: Wed, 26 Feb 2025 15:50:46 +0100
From: Martin Schiller <ms@....tdt.de>
To: "Russell King (Oracle)" <linux@...linux.org.uk>
Cc: andrew@...n.ch, hkallweit1@...il.com, davem@...emloft.net,
	edumazet@...gle.com, kuba@...nel.org, pabeni@...hat.com,
	netdev@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH net-next] net: sfp: add quirk for FS SFP-10GM-T copper
 SFP+ module

On 2025-02-26 15:38, Russell King (Oracle) wrote:
> On Wed, Feb 26, 2025 at 03:10:02PM +0100, Martin Schiller wrote:
>> Add quirk for a copper SFP that identifies itself as "FS" 
>> "SFP-10GM-T".
>> It uses RollBall protocol to talk to the PHY and needs 4 sec wait 
>> before
>> probing the PHY.
>> 
>> Signed-off-by: Martin Schiller <ms@....tdt.de>
>> ---
>>  drivers/net/phy/sfp.c | 5 +++--
>>  1 file changed, 3 insertions(+), 2 deletions(-)
>> 
>> diff --git a/drivers/net/phy/sfp.c b/drivers/net/phy/sfp.c
>> index 9369f5297769..15284be4c38c 100644
>> --- a/drivers/net/phy/sfp.c
>> +++ b/drivers/net/phy/sfp.c
>> @@ -479,9 +479,10 @@ static const struct sfp_quirk sfp_quirks[] = {
>>  	// PHY.
>>  	SFP_QUIRK_F("FS", "SFP-10G-T", sfp_fixup_fs_10gt),
>> 
>> -	// Fiberstore SFP-2.5G-T uses Rollball protocol to talk to the PHY 
>> and
>> -	// needs 4 sec wait before probing the PHY.
>> +	// Fiberstore SFP-2.5G-T and SFP-10GM-T uses Rollball protocol to 
>> talk
>> +	// to the PHY and needs 4 sec wait before probing the PHY.
>>  	SFP_QUIRK_F("FS", "SFP-2.5G-T", sfp_fixup_fs_2_5gt),
>> +	SFP_QUIRK_F("FS", "SFP-10GM-T", sfp_fixup_fs_2_5gt),
> 
> Which makes sfp_fixup_fs_2_5gt mis-named. Please rename.

OK, I'll rename it to sfp_fixup_rollball_wait.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ