[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <3c4e6613-f7fc-4105-b4ce-d959769f2944@lunn.ch>
Date: Wed, 26 Feb 2025 17:56:58 +0100
From: Andrew Lunn <andrew@...n.ch>
To: Martin Schiller <ms@....tdt.de>
Cc: Kory Maincent <kory.maincent@...tlin.com>,
"Russell King (Oracle)" <linux@...linux.org.uk>,
hkallweit1@...il.com, davem@...emloft.net, edumazet@...gle.com,
kuba@...nel.org, pabeni@...hat.com, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH net-next] net: sfp: add quirk for FS SFP-10GM-T copper
SFP+ module
On Wed, Feb 26, 2025 at 05:51:42PM +0100, Martin Schiller wrote:
> On 2025-02-26 17:27, Kory Maincent wrote:
> > On Wed, 26 Feb 2025 16:55:38 +0100
> > Martin Schiller <ms@....tdt.de> wrote:
> >
> > > On 2025-02-26 16:26, Kory Maincent wrote:
> > > > On Wed, 26 Feb 2025 15:50:46 +0100
> > > > Martin Schiller <ms@....tdt.de> wrote:
> > > >
> > > >> On 2025-02-26 15:38, Russell King (Oracle) wrote:
> > > [...]
> > > [...]
> > > [...]
> > > >>
> > > >> OK, I'll rename it to sfp_fixup_rollball_wait.
> > > >
> > > > I would prefer sfp_fixup_fs_rollball_wait to keep the name of the
> > > > manufacturer.
> > > > It can't be a generic fixup as other FSP could have other waiting time
> > > > values
> > > > like the Turris RTSFP-10G which needs 25s.
> > >
> > > I think you're getting two things mixed up.
> > > The phy still has 25 seconds to wake up. With sfp_fixup_rollball_wait
> > > there simply is an additional 4s wait at the beginning before we start
> > > searching for a phy.
> >
> > Indeed you are right, I was looking in older Linux sources, sorry.
> > Still, the additional 4s wait seems relevant only for FS SFP, so it
> > should
> > be included in the function naming to avoid confusion.
> >
>
> You may be right for the moment. But perhaps there will soon be SFP
> modules from other manufacturers that also need this quirk.
Since these are all kernel internal implementation details, we can
rename them any time we want. There is no kernel ABI involved. So
please use a name based on what we know now. If such a module does
appear sometime in the future, we can change the name at that point.
Andrew
Powered by blists - more mailing lists